Bug 259761 - 4.4.2.1-1.fc6 update changes the value of _host
4.4.2.1-1.fc6 update changes the value of _host
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-28 07:49 EDT by Yanko Kaneti
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.4.2.2-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-06 03:43:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yanko Kaneti 2007-08-28 07:49:47 EDT
# rpm -q rpm redhat-rpm-config
rpm-4.4.2-33.fc6
redhat-rpm-config-8.0.45-9.fc6
# rpm --showrc  | grep ": _host\W"
-14: _host      i686-redhat-linux-gnu

yum update to 4.4.2.1-1.fc6

# rpm --showrc  | grep ": _host\W"
-14: _host      i686-pc-linux-gnu
Comment 1 Panu Matilainen 2007-09-10 03:32:01 EDT
Ok, verified. The various _host values get "hardcoded" into /usr/lib/rpm/macros
during build time, and in this case it looks like /etc/redhat-release has been
missing on the buildroot when 4.4.2.1-1.fc6 was built, so it hasn't been
detected as redhat-linux-gnu but a generic "pc".

Hum, I'm afraid I don't have the build logs available anymore...
Comment 2 Panu Matilainen 2007-09-10 05:22:10 EDT
Right... rpm-4.4.2 comes with a version of config.guess that detects RH, 4.4.2.1
doesn't - what a lovely mess:
[pmatilai@localhost ~]$ /usr/share/automake-1.4/config.guess
x86_64-redhat-linux-gnu
[pmatilai@localhost ~]$ /usr/share/automake-1.5/config.guess
x86_64-unknown-linux-gnu
[pmatilai@localhost ~]$ /usr/share/automake-1.6/config.guess
x86_64-unknown-linux-gnu
[pmatilai@localhost ~]$ /usr/share/automake-1.7/config.guess
x86_64-unknown-linux-gnu
[pmatilai@localhost ~]$ /usr/share/automake-1.10/config.guess
x86_64-unknown-linux-gnu
[pmatilai@localhost ~]$ /usr/lib/rpm/redhat/config.guess
x86_64-redhat-linux-gnu

On F7 and 8, /usr/lib/rpm/redhat/config.guess reports -redhat-linux-gnu, on F6
it says -pc-linux-gnu. Normal software ends up using the RH config.guess through
use of %configure but rpm itself can't as of 4.4.2.* be configured with
%configure macro so it uses whatever it happens to have and... 

I guess I'll just have to patch FC6 rpm config.guess to have RH detection, for
F7 a similar hack to what's in F8 should suffice. Oh ugh.
Comment 3 Fedora Update System 2007-10-12 16:02:28 EDT
rpm-4.4.2.2-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rpm'
Comment 4 Fedora Update System 2007-10-24 03:13:48 EDT
rpm-4.4.2.2-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Panu Matilainen 2007-10-24 03:44:00 EDT
Reopening as this is still present in FC6 package which this bug report is
against...
Comment 6 Panu Matilainen 2007-11-06 03:43:49 EST
Fixed in rpm-4.4.2.1-2.fc6 which has been pushed to updates now.

Note You need to log in before you can comment on or make changes to this bug.