Bug 25989 - hcp fails to compile c++ code with
Summary: hcp fails to compile c++ code with
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: lam   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-04 22:00 UTC by John Deisz
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-05 11:31:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Deisz 2001-02-04 22:00:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-22smp i686)


The following code compiles fine with g++ and gcc

#include <complex>
using namespace std;

int main()
{
  return 0;
}

However, when hcp (c++ compiler w/ mpi library wrapper) is used 
on the same code, the following error results:

[deisz@landau tmp-c++]$ hcp main.cc
In file included from /usr/include/g++-3/complex:8,
                 from main.cc:2:
/usr/include/g++-3/std/complext.h:314: declaration of `double hypot 
(double, double)' throws different exceptions
/usr/include/bits/mathcalls.h:150: than previous declaration `double 
hypot (double, double) throw ()'
[deisz@landau tmp-c++]$ 

Note: This error _does not_ appear when hcp from
lam-tcp-6.3.2. (rpm from the lam web site) is used.


Reproducible: Always
Steps to Reproduce:
1. Attempt to compile with g++, gcc, and hcp.
2. Perform these tests on a second Redhat 7.0 machine.
3.

Comment 1 Helge Deller 2001-02-05 12:22:09 UTC
I couldn't reproduce that problem with
- lam-6.3.3b28-1.i386.rpm   and   lam-6.3.3b47-1.i386.rpm   (both tested)
- gcc-c++-2.96-69
- glibc-devel-2.2-12

could you check/update your packages ?

Please re-open that bug, if you still have problems after upgrading your packages..


Note You need to log in before you can comment on or make changes to this bug.