Bug 25991 - spawn doesn't work in expect.
Summary: spawn doesn't work in expect.
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcltk   
(Show other bugs)
Version: 7.3
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Bill Huang
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-04 22:24 UTC by Red Hat Bugzilla
Modified: 2008-03-13 19:18 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-20 16:17:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Red Hat Bugzilla 2001-02-04 22:24:12 UTC
# expect
expect1.1>  spawn ls
Segmentation fault

Comment 1 Red Hat Bugzilla 2001-02-05 03:02:40 UTC
I think I found the problem. tcltk is not 64bit clean. That is why it
fails under ia64. There are tens of warnings like

./../generic/tclIndexObj.c:97: warning: passing arg 4 of
`Tcl_GetIndexFromObjStruct' with different width due to prototype
./../generic/tclIndexObj.c: In function `Tcl_GetIndexFromObjStruct':
./../generic/tclIndexObj.c:154: warning: cast from pointer to integer of
different size
./../generic/tclIndexObj.c: In function `Tcl_WrongNumArgs':
./../generic/tclIndexObj.c:331: warning: cast from pointer to integer of
different size

I believe if all those warnings are fixed, the ia64 problem will
go away.

Comment 2 Red Hat Bugzilla 2001-02-13 18:45:21 UTC
autoconf 64 bit doesn't seem to work. The above bugs are failing because
routines are using unions to access the same data different ways.

will defer and try to get it for gold.


Comment 3 Red Hat Bugzilla 2001-02-13 19:04:09 UTC
I have a kludge at

http://ftp.valinux.com/pub/support/hjl/ia64/

It has both srpms and rpms. It is a kludge, not
a real fix, although it works for me and
Jakub.

Comment 4 Red Hat Bugzilla 2001-02-13 20:45:03 UTC
Thanks for the patch. Need to test on the other architectures before I go with
it. Last version had problems on IA-32 and other architectures (make clean
failed on some tests-- some font related, others more serious and pointing to
something deeper)

I'm taking a look at it.


Comment 5 Red Hat Bugzilla 2003-01-16 07:50:38 UTC
Is this still a problem?

Comment 6 Red Hat Bugzilla 2003-03-20 16:17:08 UTC
Closing this for now, since it is no longer clear what
the problem was.


Note You need to log in before you can comment on or make changes to this bug.