Bug 259941 - RFE: design LiveCD "Install to Hard Drive" to run to completion on 256 MB system?
RFE: design LiveCD "Install to Hard Drive" to run to completion on 256 MB sys...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: LiveCD (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-28 08:57 EDT by xunilarodef
Modified: 2013-03-05 22:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-28 09:48:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xunilarodef 2007-08-28 08:57:38 EDT
Description of problem:
  Since beginning with Fedora 7, it is recommended to use Live images
to install on a system with only a CD-ROM drive [1] (no DVD-writing
drive), how much system memory does Fedora wish to require?  The
Fedora-8-Test-1-Live-i686 CD will boot and run on a system with 256 MB
of memory.  However, when one selects the "Install to Hard Drive" icon
on a system with 256 MB memory, lots of CD-drive thrashing and a
half-hour of wall-clock time later, anaconda has not managed to even
display its initial screen.
  Is there any interest in examining the memory consumption and 
evaluating whether the benefit of the bloat outweighs the cost of
excluding yet more late 20th century and early 21st century systems
from being able to install and run Fedora 8?  I doubt this can be
accomplished with longevity unless there is consensus for this to
be a QA-verified requirement in the future.

Version-Release number of selected component (if applicable):
Fedora-8-Test-1-Live-i686

How reproducible:
  Solidly.  Same behavior on every attempt.

Steps to Reproduce:
1. Boot from LiveCD.
2. Select the "Install to Hard Drive" icon on the desktop.

Actual results:
  Wait forever (unless more than 256 MB of memory).

Expected results:
  Since the LiveCD runs on such a system, and Fedora runs on such a
system if it is installed by some other means, it would be nice to 
use "Install to Hard Drive" to accomplish said installation on a 
system with 256 MB memory.

Additional info:
  For comparison (in hindsight), the "Install to Hard Drive"
application on the Fedora-7-Test4-i386-Live CD on this same system
with 256 MB of memory (none used for video RAM) will start, run, and
progress past the networkdevicecheck step, the network step, and only
fall victim to thrashing at the timezone step.  System Monitor shows
60 MB user memory free ... but the system is useless until it is power
cycled.  (The graphical install version booted from the Fedora 7 i386
DVD does successfully complete running in 256 MB of memory. NB. not
all such systems can read a DVD, or have a way to write a DVD from
downloaded bits, so this is not an equivalent circumvention.)

  In an attempt to understand why one never even sees the first screen
of the installer, I wanted to use strace, which is not included in the
LiveCD system.  An attempt to use Applications, Add/Remove Software
(pirut / Package Manager) to install strace in the running LiveCD
system also fails on a system with 256 MB memory.  (On another system
with more memory, one can observe that the user memory consumption
high water mark rose from ~ 180 MiB to ~ 285 MiB to run pirut to
install strace.)  Continuing this (now futile) experiment, while
running (Fedora-8-Test-1-Live-i686):

  [root@localhost ~]# strace -o /media/m/liveinstStrace.txt /usr/bin/liveinst

on another system with more memory one can observe that the user
memory consumption high water mark rose from ~ 180 MiB to ~ 228 MiB by
the time the first screen of the installer is displayed

[1] 
http://fedoraproject.org/wiki/Fedora7/FAQ#head-593830c0c322a6ad0eb7b74623c732f854827ac8
Comment 1 Jeremy Katz 2007-08-28 09:48:51 EDT
Given the way that the live CD uses system memory for holding any changes to
filesystems, etc, there's really not much we can do here.  

With Fedora 8, we're going to use available swaps by default which will help,
but there's only so much that can be done.

Note You need to log in before you can comment on or make changes to this bug.