Bug 25995 - cvs has temporary file problem with local repository
Summary: cvs has temporary file problem with local repository
Status: CLOSED DUPLICATE of bug 25173
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cvs   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard: Florence Gold
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-04 23:36 UTC by Jay Berkenbilt
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-05 23:07:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jay Berkenbilt 2001-02-04 23:36:57 UTC
Create a empty directory, say /tmp/z, and do the following:

cd /tmp/z
cvs -d /tmp/z/repo init
mkdir /tmp/z/repo/dir
cvs -d /tmp/z/repo co dir
cd dir
echo test > a
cvs add a
cvs ci -mtest
echo test >> a
cvs ci -mtest

You get an error such as this:

cvs [commit aborted]: cannot remove /tmp/cvs2kE8KN: No such file or
directory

where the file that can't be removed is a temporary file name.

Running strace shows calls to fstat64 and lstat64.  I wonder whether it's
related.

This is what Fisher with no upgrades.  I have, however, replaced the i686
glibc with the i386 in an effort to track down some threading problems.

Comment 1 Nalin Dahyabhai 2001-02-05 06:22:10 UTC
Does cvs-1.11-3 from Raw Hide (ftp://ftp.redhat.com/pub/rawhide/) fix this for
you?  There were some problems with temp-file fixes in 1.11-2 which were fixed
in -3.

Comment 2 Glen Foster 2001-02-05 22:37:29 UTC
We (Red Hat) should really try to fix this before next release.

Comment 3 Jay Berkenbilt 2001-02-05 23:06:56 UTC
Yes -- cvs-1.11-3 from rawhide behaves properly in this respsect.  I will run
with that for the duration of my Fisher testing. Hopefully including this in 7.1
will be sufficient.

Comment 4 Nalin Dahyabhai 2001-02-06 19:05:37 UTC
Okay, then I'll close this as a duplicate of the bug which was fixed in 1.11-3.

*** This bug has been marked as a duplicate of 25173 ***


Note You need to log in before you can comment on or make changes to this bug.