Bug 260041 - Same with 2.6.23-0.169.rc5.git1.fc8
Same with 2.6.23-0.169.rc5.git1.fc8
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 All
medium Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-28 09:15 EDT by Reindl Harald
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 17:08:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot vom booting VM (23.87 KB, image/png)
2007-08-28 09:15 EDT, Reindl Harald
no flags Details
VMware-Screenshot one second before reboot (97.51 KB, image/png)
2007-09-08 16:04 EDT, Reindl Harald
no flags Details

  None (edit)
Description Reindl Harald 2007-08-28 09:15:33 EDT
The old kernel starts without troubles, the new one can not find LVM
Installed on VMwareServer running od Fedora 7
See attached Screenshot....

[root@fedora-test ~]# rpm -qa | grep kernel
yum-kernel-module-1.1.6-1.fc8
kernel-headers-2.6.23-0.142.rc3.git10.fc8
kernel-devel-2.6.23-0.136.rc3.git7.fc8
kernel-2.6.23-0.142.rc3.git10.fc8
kernel-devel-2.6.23-0.142.rc3.git10.fc8
kernel-2.6.23-0.136.rc3.git7.fc8
Comment 1 Reindl Harald 2007-08-28 09:15:33 EDT
Created attachment 176301 [details]
Screenshot vom booting VM
Comment 2 Jarod Wilson 2007-08-28 15:31:52 EDT
Can you give kernels between 0.136 and 0.142 a try to narrow down where the
issue first crops up?

Available here:

http://koji.fedoraproject.org/packages/kernel/2.6.23/
Comment 3 Reindl Harald 2007-08-28 16:48:40 EDT
139, 140 and 142 have the same problem
hmm its possible that mkinitrd makes the fuck...

I have removed kernel and kernel-devel-packages that are not booting and
installed the both in all two other version with "yum --nogpgcheck localinstall"

____


If it helps you there is an tar-image available from the vmware-setup
My connection has 2Mbit Upload, so it may take a while for 7.3 GB
ftp://fedora:fedora@local.rhsoft.net/Fedora.tar

System starts in "init 3" and prefers kde for waiting on kde4-snaps
There is a normal user "harry" with password "linuxuser" and all
sudo-permissions and root has the same password

Comment 4 Greg Monahan 2007-08-28 17:46:11 EDT
142 doesn't find LVM on non-VMWare laptop
139 works 100%
Comment 5 Reindl Harald 2007-08-28 17:51:07 EDT
OK, seems that the problem with 139 began on vmware and now the same happens on
"real-hosts"...

I hope VMware-support will be better in many cases - Installing FC7/FC8-test1 on
SCSI-Drive under VMware do not work, with IDE-Emulation it hangs without
comments if you create your own partitions.

Its a bit painful because i have not enough computers for playing with
devel-snapshots on real hardware :-)
Comment 6 Jarod Wilson 2007-08-28 18:04:54 EDT
Hrm... So one report of 139 working fine, one of it not working... I'm certainly
inclined to think mkinitrd could well be at least partially responsible... I've
got 142 booting on multiple systems of my own right now, but I don't think I
updated mkinitrd on them in the past few days.
Comment 7 Reindl Harald 2007-08-28 18:19:46 EDT
The timestamps are not the same as on your bugzilla-server but on the second
output you see coming the non-botting kernel 142 and mkinitrd in one action

[root@fedora-test ~]# cat /var/log/messages | grep mkinitrd
Aug 28 14:57:28 fedora-test yum: Updated: mkinitrd - 6.0.12-1.fc8.i386#000

Aug 28 14:57:27 fedora-test yum: Updated: nash - 6.0.12-1.fc8.i386#000
Aug 28 14:57:28 fedora-test yum: Updated: mkinitrd - 6.0.12-1.fc8.i386#000
Aug 28 14:57:41 fedora-test yum: Updated: vim-common - 2:7.1.87-1.fc8.i386#000
Aug 28 14:57:43 fedora-test yum: Updated: perl-DBI - 1.58-2.fc8.i386#000
Aug 28 14:57:44 fedora-test yum: Installed: beecrypt-devel - 4.1.2-13.i386#000
Aug 28 14:57:45 fedora-test yum: Updated: vim-enhanced - 2:7.1.87-1.fc8.i386#000
Aug 28 14:58:29 fedora-test yum: Installed: kernel -
2.6.23-0.142.rc3.git10.fc8.i686#000
Comment 8 Reindl Harald 2007-08-31 20:04:33 EDT
With the last kernel-update it works again, but cant say if kernel himself or
the new mkinitrd did the trick - please look for better vmware-support on fedora
in future especially installing from dvd-image :-)

Installing:
 kernel                  i686       2.6.23-0.149.rc4.fc8  development        16 M
 kernel-devel            i686       2.6.23-0.149.rc4.fc8  development       4.6 M
Updating:
 kernel-headers          i386       2.6.23-0.149.rc4.fc8  development       660 k
Comment 9 Jarod Wilson 2007-09-03 22:54:11 EDT
If I'm not mistaken, this wasn't a vmware-specific issue, it actually rendered some physical machines 
unbootable as well.
Comment 10 Reindl Harald 2007-09-08 16:02:48 EDT
Hmm 2.6.23-0.169.rc5.git1.fc8 Says booting "ABCDE...", restarts the VM says the
same, restarts the VM the whole day :-(

2.6.23-0.169.rc5.git1.fc8 has no problems
Same VMware-Installation
I hope its ok tu use the same bug-report instead of opening an new....
Comment 11 Reindl Harald 2007-09-08 16:04:06 EDT
Created attachment 190861 [details]
VMware-Screenshot one second before reboot
Comment 12 Jarod Wilson 2007-09-13 17:08:03 EDT
That last one's actually a dupe of another bug, which escapes me. Was affecting
physical machines as well, and was fixed in a later kernel.

Note You need to log in before you can comment on or make changes to this bug.