Bug 26049 - Unable to install / unable to load *after* installation.
Unable to install / unable to load *after* installation.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-04 22:06 EST by Elton Woo
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-09 20:01:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elton Woo 2001-02-04 22:06:01 EST
Initial attempt to install Fisher beta locks up when Anaconda is invoked
from either graphic
or text mode. Cause: pointer device Logitech Optical Wheel Mouse is
detected as PS/2
mouse *only*, even when PS/2 support is disabled in the BIOS, and the mouse
is connected
via the USB port.

Additional attempt to install Fisher (default, or expert mode): fstab is
NOT created.

System specs: 
CPU:AMD k2/500 (slightly overclocked @ 523 Mhz)
System memory: 128 Mb (PC-100)
Mobo: Acer AX59PRO Rev. 235, Award BIOS
Floppy device:  LS-120 VER5 00 UHD Floppy (ATAPI/IDE, attached as /dev/hdc)
Hard disk: QUANTUM FIREBALLP LM15 (/dev/hda)
Keyboard: MFG="unknown" PS/2 connection
Pointer device: Logitech Optical Wheel Mouse (USB or PS/2 connection)
Video card: Jaton 3DForce B-32 Plus (AGP - NVIDIA-TNT2 Vanta [NV6] chip)
Monitor: Viewsonic 17
CDROMs:  TOSHIBA CD-ROM XM-6002B (ATAPI/IDE - /dev/hdb)
	 YAMAHA CRW6416S (SCSI - /dev/scd0)
SCSI: Adaptec AHA-7850
Network Card: SMC-EZ10 (PCI - RTL-8029(AS)
Sound Card: Ensoniq 64 (ES1371 [AudioPCI-97] )
Printer: Epson Stuyus Color ESC/P2 (parallel-port only - /dev/lp0)
Scanner: Epson Perfection 610u

	I can only install Fisher if I use the supplied adapter and connect the
mouse to
the PS/2 port. The main problem is that the fstab file is NOT created!!

I *would* like to try this public beta....   :-(


Elton Woo
Comment 1 Elton Woo 2001-02-05 14:41:50 EST
Floppy is disabled both in the BIOS as well as via physical connections 
(i.e. there is no floppy *physically connected* to the motherboard). 

The Quantum Fireball (15 Gb) has a primary DOS/Windows partition, with
the rest of free space dedicated to linux ONLY. This is the Primary Master
with the TOSHIBA CD-ROM as the Primary Slave.

The LS-120 super disk "floppy" device is attached as the Secondary
Master drive. 

I have made several downloads of the Fisher Disk1, with each download
correctly verified agains the md5sum. Three separate (Disk 1) CD's
created in Mandrake 7.2, with no errors.

Another attempt today, results in the same failure [4/5 th Feb. 2001]

respectfully,

Elton Woo.
Comment 2 Michael Fulbright 2001-02-06 12:44:20 EST
I am confused - what does creating the fstab file have to do with a USB mouse
not being detected? Please elaborate.

We've fixed the USB mouse detection internally since the Fisher release, btw.
Comment 3 Elton Woo 2001-02-06 13:46:30 EST
Mille excuses! I should  clarify that. The usb mouse detection is not related.
Sorry for the misunderstanding.  
To begin with, when I had the lockups with the usb mouse, I attempted various
solutions: 
disabled *all* IRQ's in the BIOS, disabled PS/2 (the keyboard still worked),
disabled video RAM shadowing, disabled PnP. Finally since RH kept insisting it
was a PS/2
mouse I attached the adapter plug that comes with the wheel mouse, and was able
to
proceed with the installation.

I opted for "epsert" mode, so that I could select the packages individually. 
Once the install
routine completed and the machine rebooted, it was *then* the system complained
about
the fstab file not being found or created....

My next attempt was to do a simple basic install, choosing "Workstation". Again:
reboot.
and "no fstab".  Of the 15Gb, I have only 2Gb dedicated to Windows98. The rest
of the 
drive is Mandrake 7.2.  Regardless of any bugs, I'm sufficiently confident in RH
linux, that
I intended to replace Mandrake with Fisher. 

 ... but without fstab... I'm "fstuck"!!  ;-))
Comment 4 Michael Fulbright 2001-02-08 13:17:17 EST
Try this - restore your system with its IRQs enabled in its original state.

Instead of using 'expert' mode, try adding 'nousb'. This will avoid USB probing.
Make sure you have a PS/2 mouse attached.
Comment 5 Elton Woo 2001-02-09 20:01:43 EST
I have now succeeded in installing the Fisher beta, so kindly consider this bug closed. Out of
*three* separate downloads and burns, it turns out that *two* burns of CD2 were defective.
 ... not enough to abort the install, but sufficiently corrupted to cause the "post-installation" failure.

First, I tried doing a basic install which would require *only* Disk1. Then a more selective install which
required the extra CD. This is the first time that I've had a problem with a "successfully created" CD.

  ...and what are the odds of *two* of *three* being defective (same Disk2).

 ... I regret any inconvenience this may have caused... Now I have my Epson USB scanner running
under Fisher (thanks to instructions from the redhat list) ... next, to configure the USB mouse, which
is still running as, and with the PS/2 connection.

    with best wishes,

  Elton Woo ;-)
Comment 6 Michael Fulbright 2001-02-12 13:46:44 EST
Thanks for letting us know it finally worked for you.

Note You need to log in before you can comment on or make changes to this bug.