Bug 26052 - A system resource was used up and resulted in crash.
A system resource was used up and resulted in crash.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-04 23:59 EST by Tod Liebeck
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 19:35:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tod Liebeck 2001-02-04 23:59:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.11 i686; Nav)


My apologies for the vague description, as I really have very little idea
what happened.  As far as I can tell, some system resource was consumed
which blocked most processes from getting anything done.  I was downloading
a 20M file over my modem, compiling Flight Gear, and had a few
gnome-terminals open.  The Flight Gear compilation stopped and just sat,
using no CPU.   Much of the Gnome-panel hung, except for the desktop
switching applet.  I went to another desktop where a terminal was open (I
couldn't launch new terminals), and did a "killall panel".   This had no
effect except hanging the terminal (Ctrl+C'ing killall panel did not give a
bash prompt.)  I then switched back to the desktop with the compilation in
progress and Ctrl+C'd it, and was greeted with a bash prompt.  I tried
"killall -9 panel" and had the same result as before.  Hit Ctrl+Alt+F1 to
log in as root.  Typed "root" and hit enter and it just sits there, no
password prompt.  Did this on a few more terminals with same effect. 
Switched back to X (Ctrl+Alt+F7) and hit Ctrl+Alt+Backspace to kill it.  
At this point console was entirely frozen, with a blank screen.
(Ctrl+Alt+Whatever) did nothing.)   Could not SSH from other boxes to shut
machine off.  Crashed machine would respond to ping, nothing else.  At this
point I shut it off and at boot it forced me to manually run e2fsck.

Again I apologize for this long-winded and uninformative bug report, but I
just have absolutely no idea what happened.  This system is heavily used
and normally would only be rebooted for kernels and hardware upgrades, it's
never crashed with 7.0.

Please email me if you need information, system specs, etc.

The only thing I can think of is that this bug and my last wierd system
crash bug (#25894), are somehow related to the bug in magicdev that I will
be posting next.  

Reproducible: Didn't try
Steps to Reproduce:
1.
2.
3.
Comment 1 Arjan van de Ven 2001-02-05 07:30:36 EST
Do you have more than 1Gb of RAM ?
Comment 2 Tod Liebeck 2001-02-05 13:29:16 EST
The system has 256M memory and 256M swap.
Comment 3 Glen Foster 2001-02-05 17:04:40 EST
If you have any success reproducing this defect we'll have a much better chance
of analyzing (and perhaps fixing) this problem.  Please provide more data here
in this bug as you get it.
Comment 4 Michael K. Johnson 2001-02-08 17:47:11 EST
Chances are very good that this is a VM bug; we have fixed several
VM bugs in our current tree since we built the fisher kernel.

Note You need to log in before you can comment on or make changes to this bug.