Bug 26056 - no lilo configuration selections during workstation install
no lilo configuration selections during workstation install
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-05 00:41 EST by sandy
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-06 17:54:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description sandy 2001-02-05 00:41:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)


People with multi boot OS systems are very
unhappy when, after they install a new OS,
they are default booted into the new OS and 
the present OS boot setups are overwritten.

During a normal install the user should be able to select how
to configure lilo (what will be the default boot OS or 
whether to install lilo at all or use a floppy boot instead).

Even after I installed fisher I could not find any
GUI to help me re-configure lilo.  I had to manually
edit the lilo.conf file.  Redhat has done a 
great job making Linux easy to install, however, this
is completely defeated when you force these lilo 
choices on a user and then make it difficult re-setup
or reconfigure how to boot the various installed OSes.

Take a look at Mandrake ... they do a much better
job with this.  Redhat needs to improve this very basic 
and extremely important part of the Linux OS install
process.  Otherwise you will discourage many of the 
people you would have otherwise attracted with
your improved GUI install.

Also, it would be very helpful if you saved the existing boot
sector before the install and then made it easy for
a user to recover the original after install (place a
hint in an obvious place of how to recover the original
boot setup).

BTW what's with the hideous lilo boot screen ...
the colors are so bright it nearly knocked me off my
chair during my first re-boot.


Reproducible: Always
Steps to Reproduce:
1. install fisher with workstation defaults
2. 
3. 

Actual Results:  

1. your boot sector is overwritten without warning.

2. you have no easy way to recover.

Expected Results:  

  At least a warning that this will occur
Comment 1 keith adamson 2001-02-05 19:50:58 EST
Also see discussion on Kernel Trafic;

http://kt.linuxcare.com/kernel-traffic/latest.epl
Comment 2 Michael Fulbright 2001-02-06 13:39:43 EST
The workstation install is a simplified method to install a system which
automatically fills in several steps.

If you had run a Custom install you would have been prompted about LILO
configuration.

You can restore the MBR for most Microsoft OS's using the fdisk /mbr command.

Finally, if you know of a multi-boot environment which the automatic LILO
configuration the workstation class install used which did not do the right
thing, please give us information so we can improve the method it uses.
Comment 3 sandy 2001-02-06 17:54:49 EST
It worked fine ... I just thought the users should be
given an option, similar to the option to selecting the
disk partitioning config. It is inconsistent to allow
the user the option to select the hard drive partition
config but not allow the user the option to select the
boot time lilo config (in my mind a user will either
default both or want to configure both). In any case,
once you find out that you can't configure the boot
using the Workstation install you've already installed
Linux and are ready to reboot the installed system, as
there is no warning.
 
I really want a standard simple Workstation install
and the option to configure the hard disk partitions
and the boot configuration. I believe this is a common
preference among your users. At a minimum it should be
clear upfront that you requires a "custom" install if
you want to configure the boot.
 
However, please understand I DO NOT WANT A CUSTOM
SOFTWARE INSTALL. I WANT A STANDARD SIMPLE 
WORKSTATION INSTALL WHERE I CAN CONFIGURE THE DISK 
PARTITION AND THE BOOT SETTINGS. These two items 
really don't have much in common with selecting a 
custom software configuration for Linux. They are 
more related to the network configuration, which 
BTW you also allow the user the option to choose 
during the Workstation install.
 
Is there a GUI tool for helping to configuring 
Grub and/or Lilo in the Redhat distro after 
installation?
Comment 4 Michael Fulbright 2001-02-28 10:30:00 EST
I don't know of a tool for post-install configuration of the boot loader of your
choice (grub or lilo). I would recommend looking on http://freshmeat.net, it is
a good listing of available software for Linux.

We are working on making the expert and novice versions of the installer more
separate, instead of trying to fit both into one as we do now.  Future versions
will do this better.

Marking as wontfix because we can't make these changes now.


Note You need to log in before you can comment on or make changes to this bug.