Bug 260741 - anaconda-ks.cfg script should be created earlier during install
anaconda-ks.cfg script should be created earlier during install
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-28 12:12 EDT by Mike Hanby
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-14 12:41:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Hanby 2007-08-28 12:12:15 EDT
Description of problem:
I had a manual install fail on a server due to a single package not being found
on the disk. I couldn't get the installer past the problem and my only real
option was to reboot and try again.

No problem, I'll just take the kickstart file, remove the offending package, and
reinstall using anaconda-ks.cfg to automate it.

I switched to VT 2 and figured I'd copy the /mnt/sysimage/root/anaconda-ks.cfg
file over to floppy. The file isn't there.

I guess this file doesn't get created until the install completes.  Wouldn't it
make more sense for the file to get generated after the partitions are formatted
and mounted to /mnt/sysimage?


Version-Release number of selected component (if applicable):
RHEL 5 x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Kick off a CD based manual install
2. After the package installation begins, switch to VT 2
3. Check /mnt/sysimage/root/ for the anaconda-ks.cfg file
  
Actual results:
The file isn't there until after package installation

Expected results:
The file would be there after the partitions were formatted and mounted so that
you could restart the install using kickstart if a fatal installation error
occurred during the package process.

Additional info:
Not a biggy, it just seems out of order.
Comment 1 RHEL Product and Program Management 2007-09-14 12:41:53 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.