Bug 2609 - new LILO confuses SystemSoft BIOS
new LILO confuses SystemSoft BIOS
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: lilo (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-06 16:17 EDT by eric
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-01 18:31:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eric 1999-05-06 16:17:30 EDT
The version of LILO included with Red Hat 6.0 apparently
confuses the SystemSoft BIOS used on many low-cost AMD-based
laptop computers using the Intel TX Socket-7 chipset. It
apparently does not detect a valid boot signature on the
hard drive and refuses to load and run the boot sector.
Instead, the BIOS prompts for a floppy.

The computer boots up fine off of the boot floppy. Various
configurations of /etc/lilo.conf were tried:
   a)  Use "fdisk /mbr" from a Windows floppy, then set the
Linux partition as active. Use boot floppy into Linux, set
lilo.conf to write boot record to /dev/hda3 (the Linux root
partition). Run /sbin/lilo then reboot. Same result (BIOS
prompts for a floppy upon reboot).
  b) Use boot floppy into Linux, set lilo.conf to write boot
record to /dev/hda. Same result (BIOS prompts for a floppy
upon reboot).

Temporary work-around: boot off of the boot floppy,
downgrade to the Red Hat 5.2 version of LILO and run
/sbin/lilo . (With the same /etc/lilo.conf that did not work
with the Red Hat 6.0 version of LILO).

Note: This appears to be a BIOS-specific interaction. No
problems have yet been observed with LILO on desktop
machines using the AWARD or Phoenix BIOS.
Comment 1 David Lawrence 1999-06-01 18:31:59 EDT
We will need to obtain hardware that contains this brand of BIOS to
accurately troubleshoot the problem associated with LILO shipped with
6.0. This may take a while.

Note You need to log in before you can comment on or make changes to this bug.