Bug 26096 - java doesn't work in mozilla 0.7
java doesn't work in mozilla 0.7
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-05 10:24 EST by Christopher Blizzard
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-13 12:03:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Blizzard 2001-02-05 10:24:19 EST
Java doesn't work in mozilla 0.7.
Comment 1 Christopher Blizzard 2001-02-09 13:01:09 EST
I've done some investigation and this looks like it's a glibc issue.  You can
use bits of the standalone java VM that mozilla uses and those standalone parts
don't work on the 7.1 beta.

You can get a copy of the standard jdk code at:

http://people.redhat.com/blizzard/java2.tar.bz2

If you untar it you should be able to cd into the bin/ directory and run ./java
-version and it should print out a version string.  It works on 7.0, anyway.
Comment 2 Jakub Jelinek 2001-02-13 08:02:39 EST
This is a buggy JDK (it has hardcoded knowledge about thread stacks being 2MB
in size aligned to that size). We're now discussing what do with that.

Particularly at least os::Linux::install_alternate_signal_stack(void)
contains this bug.
Comment 3 Christopher Blizzard 2001-02-13 12:02:56 EST
Opening up so that the sun people can look at this bug.
Comment 4 Jakub Jelinek 2001-03-21 08:04:34 EST
Should be fixed in glibc-2.2.2-7 and Sun is actually working on a fix using
pthread_getattr_np.

Note You need to log in before you can comment on or make changes to this bug.