Bug 26116 - Extraneous characters in PHP forms
Extraneous characters in PHP forms
Status: CLOSED DUPLICATE of bug 24933
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-05 13:02 EST by Need Real NameMichael J. Fiorill
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-05 13:04:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Inital HTML form containing drop down box (114 bytes, text/plain)
2001-02-05 13:04 EST, Need Real NameMichael J. Fiorill
no flags Details

  None (edit)
Description Need Real NameMichael J. Fiorill 2001-02-05 13:02:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Mac_PowerPC)


Any form submitted with a <form> tag containing  
ENCTYPE="multipart/form-data"  will produce extraneous carriage 
returns preceeding any submitted data. If the ENCTYPE isn't 
specified this problem doesn't occur. This only seems to happen in 
the new update php-4.0.4pl1-3. I have included a form and the PHP 
script that documents the error on our system.

Reproducible: Always
Steps to Reproduce:
1. Create an HTML form with a tag of  <FORM 
ENCTYPE="multipart/form-data" ACTION="form_process.php" 
METHOD=POST>

2. In the receiving script, print out a form field. Use either the <PRE> 
tag, or look at the source to see the newline character inserted before 
the form field.
3.
	

This bug doesn't become severe until dealing with databases. The 
extra newline causes problems with matching for foreign keys. It 
seems like a logical fix would be to remove the 
ENCTYPE="multipart/form-data" part of the form tag. However, 
according to PHP, this part is required when doing file uploads.
Comment 1 Need Real NameMichael J. Fiorill 2001-02-05 13:04:33 EST
Created attachment 9039 [details]
Inital HTML form containing drop down box
Comment 2 Nalin Dahyabhai 2001-02-05 19:45:12 EST
Please check if the errata candidates in http://people.redhat.com/nalin/test/
fix this for you.  I'm quite certain that this is the same as bug #24933.

*** This bug has been marked as a duplicate of 24933 ***

Note You need to log in before you can comment on or make changes to this bug.