Bug 261201 - lyx-xforms needs missing lyx dependecy
lyx-xforms needs missing lyx dependecy
Product: Fedora
Classification: Fedora
Component: lyx (Show other bugs)
All All
medium Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-08-28 14:17 EDT by John Guthrie
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-29 22:11:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
output of command 1-5 (6.36 KB, text/plain)
2007-08-29 00:57 EDT, John Guthrie
no flags Details
output of commands 1a-4a (4.09 KB, text/plain)
2007-08-29 00:59 EDT, John Guthrie
no flags Details

  None (edit)
Description John Guthrie 2007-08-28 14:17:02 EDT
Description of problem:
When I try to update using yum, I get the following error:

Error: Missing Dependency: lyx = is needed by package lyx-xforms

I understand that lyx-xforms is deprecated.  (At least, that's what it says in
the RPM description.)  So if lyx-xforms depends on a version of lyx that is no
longer being offered as part of lyx-1.5.x, shouldn't we at least be obsoleting
lyx-xforms in the lyx RPM?  Alternatively, I suppose we could offer some kind of
compat-lyx package, although I would be really surprised if we wanted to do that
for a deprecated package.

Version-Release number of selected component (if applicable):

How reproducible:
Every time.

Steps to Reproduce:
1. Install Fedora Core 6
2. Install lyx lyx-xforms version 1.4.4-2.fc6
3. Run "yum update lyx\*"
Actual results:
I get the error indicated above.

Expected results:
I would expect a successful install.  Whether this meant that lyx-xforms was
un-installed in the process, I'm not certain.

Additional info:
Comment 1 Rex Dieter 2007-08-28 14:58:19 EDT
Um, lyx.spec includes:
Obsoletes: %{name}-qt < %{version}-%{release}
Provides:  %{name}-qt = %{version}-%{release}
Obsoletes: %{name}-xforms < %{version}

So that *should* be taken care-of, unless you're trying:
yum update lyx lyx-qt lyx-xforms
which probably won't work.

$ yum update
*should* do the right thing.  If not, say so.
Comment 2 John Guthrie 2007-08-29 00:53:12 EDT
Something wierd is happening.  If I do the following:

1. yum clean metdata
2. yum clean dbcache
3. yum list udpates
4. yum update (but press "N" and cancel)
5. yum update lyx\*

Then I am able to reproduce the error %100 percent of the time.  Note that
command #4 actually would have worked properly, with lyx replacing lyx-xforms. 
I just happened to cancel that command.  However, if I run the following
sequence, removing command #4 above:

1a. yum clean metadata
2a. yum clean dbcache
3a. yum list udpates
4a. yum update lyx\*

Then I get the error again.  yum does not like my specifying just the lyx
packages, but is fine updating everything.  I am going to attach the output of
the above command sequences momentarily.
Comment 3 John Guthrie 2007-08-29 00:57:30 EDT
Created attachment 177921 [details]
output of command 1-5

Here is the output from commands 1-5 in comment #2.
Comment 4 John Guthrie 2007-08-29 00:59:33 EDT
Created attachment 177941 [details]
output of commands 1a-4a

Here is the output from commands 1a-4a in comment #2 above.
Comment 5 Rex Dieter 2007-08-29 07:24:40 EDT
Wrong: yum update lyx\*
Right: yum update lyx
Right: yum update

Try again.
Comment 6 John Guthrie 2007-08-29 22:11:47 EDT
Yeah, "yum update lyx" works.  I guess the problem was that I was trying to
update a package that was supposed to go away.  Thinking about it, I can imagine
that condition generates undefined behavior.  The phrase of the moment is, "Duh."

(Sheepishly) Everything works here now.  I'll go ahead and close this bug out
and mark it NOTABUG.

Thank you very much for all of your help.  It is very appreciated.

Note You need to log in before you can comment on or make changes to this bug.