Bug 261601 - net-snmp RawCPU counter broken
net-snmp RawCPU counter broken
Status: CLOSED DUPLICATE of bug 223775
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-snmp (Show other bugs)
4.5
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Jan Safranek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-28 16:13 EDT by Chuck Mead
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 03:37:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chuck Mead 2007-08-28 16:13:44 EDT
Description of problem:

The idle counter in /proc/stat (5th column - 26752194897 in this case) is much
larger than a 32 bit number. The snmpd agent is doing a sscanf %lu on this and
as such returns 4294967295. This has been fixed two years ago and applies to
all ssRawCPU counters and others. The fix is basically %llu on the values.



Version-Release number of selected component (if applicable):
net-snmp-5.1.2-11.EL4.10.0.1


How reproducible:

snmpwalk -v1 -cpublic localhost ssCpuRawIdle.0;head -n1 /proc/stat

Steps to Reproduce:
1. snmpwalk -v1 -cpublic localhost ssCpuRawIdle.0;head -n1 /proc/stat
2.
3.
  
Actual results:
UCD-SNMP-MIB::ssCpuRawIdle.0 = Counter32: 4294967295
cpu  259515841 311084 138251888 26752194897 27766490 936245 0


Expected results:
The Mib output from line #1 should have rolled over... it never does.

Additional info:

This bug was reported 2 years ago on sf.net and I believe has already been fixed
upstream.

http://sourceforge.net/tracker/index.php?func=detail&aid=1197183&group_id=12694&atid=112694
Comment 1 Jan Safranek 2007-08-29 03:37:51 EDT
shall be fixed in RHEL 4.6

*** This bug has been marked as a duplicate of 223775 ***

Note You need to log in before you can comment on or make changes to this bug.