Bug 262101 - system-config-bind Initialization Error: chown named:named invalid user
system-config-bind Initialization Error: chown named:named invalid user
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: system-config-bind (Show other bugs)
7
All All
medium Severity low
: ---
: ---
Assigned To: Ondrej Dvoracek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-28 20:04 EDT by Eric Moret
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 23:53:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Moret 2007-08-28 20:04:15 EDT
Description of problem:
When starting system-config-bind for the first time following bind install and
no prior configuration of bind, initialization fails with the following message
in a GTK dialog box:
Error
Initialization Error:
Configuration could not be initialized from defaults: /bin/chown: `named:named':
invalid user

This is most likely due to bind not creating the named default user anymore but
only the named group.


Version-Release number of selected component (if applicable):
bind-9.4.1-9.P1.fc7
system-config-bind-4.0.2-6.fc7

How reproducible:
Always

Steps to Reproduce:
1. install bind and system-config-bind on a clean (as in no prior bind config) box
2. start system-config-bind
  
Actual results:
Get the above describe error message box

Expected results:
system-config-bind should go ahead with initialization and not use chown but
instead use chgrp to set rights on configuration files
Comment 1 Ondrej Dvoracek 2007-08-29 07:31:20 EDT
Hi,
I installed both packages on F7/x86_64. The bind package created the named user
and group and the system-config-bind package created initial default bind
configuration and normally started. 
Versions of tested packages are the same, so I'm not able to reproduce it.
Please, try it again and let me know if you have any other details.
I will ask the bind package maintainer whether it is possible that the bind
package doesn't create named user during installation, but I don't think so.
Cheers, Ondrej
Comment 2 Eric Moret 2007-08-29 23:53:32 EDT
Weird, I am not able to reproduce either.

Note You need to log in before you can comment on or make changes to this bug.