Bug 26213 - Dell Latitude LS500 - Warm Boot Problems (hda: timeout waiting for DMA)
Summary: Dell Latitude LS500 - Warm Boot Problems (hda: timeout waiting for DMA)
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard: Florence Gold
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-05 21:01 UTC by David Sainty
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-09 14:55:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hwconf from the LS500 (2.26 KB, text/plain)
2001-02-05 22:22 UTC, David Sainty
no flags Details

Description David Sainty 2001-02-05 21:01:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.17-9 i686; en-US; m18)
Gecko/20001107 Netscape6/6.0


During startup:

Partition check:
 hda:hda: timeout waiting for DMA
ide_dmaproc: chipset supported ide_dma_timeout func only: 14
hda: irq timeout: status=0x58 { DriveReady SeekComplete DataRequest }
hda: timeout waiting for DMA
<repeated a few times>
hda: DMA disabled
ide0: reset: success


Reproducible: Always
Steps to Reproduce:
1.Install fisher on Dell latitude LS500.
2.Boot the standard 2.4.0-0.99.11 kernel.
	

Actual Results:  The error messages as in the description.

Expected Results:  No IDE DMA errors.

Comment 1 David Sainty 2001-02-05 22:16:12 UTC
The problem only occurs after a **warm** boot on the machine. There are also
problems with Ethernet on the machine! (Machine = Dell Inspiron LS500, NeoMagic
256 + PIII 500MHz)

Networking is 3Com PCI 3c905c Tornado at 0xfc00, IRQ 10, product code '' rev
00.14 date 10-10-99, 8K byte-wide RAM 5:3 Rx:Tx split, autoselect/Autonegotiate
interface, MII transceiver found at address 24, status 782d, enabling bus-master
transmits and whole-frame receives, eth0: using NWAY autonegotiation

I can test anything people have to test.

Comment 2 David Sainty 2001-02-05 22:22:46 UTC
Created attachment 9079 [details]
hwconf from the LS500

Comment 3 Glen Foster 2001-02-05 22:44:36 UTC
Changing product to "Red Hat Linux Beta"

Comment 4 Glen Foster 2001-02-05 22:46:34 UTC
This defect is considered MUST-FIX for Florence Gold release

Comment 5 Michael K. Johnson 2001-02-08 23:06:22 UTC
Have you tried a more recent kernel?

Comment 6 David Sainty 2001-02-14 22:24:32 UTC
Trying kernel tonight....


Comment 7 David Sainty 2001-02-14 23:29:21 UTC
Okay, I went from fisher to kernel-2.4.1-0.1.8, glibc 2.2.1-7 and
XFree86-4.0.2-7. The problem is the same as before. No different wrt colour.


DS..

Comment 8 Michael K. Johnson 2001-02-14 23:33:56 UTC
"colour"?

Comment 9 David Sainty 2001-02-14 23:56:18 UTC
(D'oh! I have another bug in for framebuffer with purple coloured screens on
this machine. I typed in the wrong window. :-( )

Regarding _this_, it seems much better, but not perfect. I'm not getting errors
now, and when it _does_ warm reboot back to Linux, it seems to do so
properly(*). Its not perfect because I have rebooted about 9 times, and 3 times
I still got freezes at the Dell BIOS screen after the Linux shutdown. I have not
yet been able to hit <ESC> before this has happened, to get more BIOS output.

* - "properly" in terms of network and IDE.  I now get USB/IRQ problems and get
consistent all-the-time "usb-uhci.c: interrupt, status x, frame #0" (where
x={10,20,30}) errors however which scrolls down the console, approximately one
per second. This is a seperate problem though!


Comment 10 David Sainty 2001-02-15 00:00:39 UTC
I should also mention that the BIOS freeze is severe. I have to remove AC and
battery power first to kill the machine.

I didn't notice this with 7.0 (and 2.2.16-22) on _this_ particular machine,
although I also only briefly had it installed. We have other machines here like
it however (400MHz instead of 500) running 7.0 in daily service, and I don't
know of any problems with them.


Comment 11 Michael K. Johnson 2001-02-15 00:34:53 UTC
Since the IDE problems went away, I'm closing this.  Please
open new bug reports for other problems, or append yourself
to existing ones.

Comment 12 David Sainty 2001-02-23 17:01:46 UTC
Bad news - the problem is BACK with wolverine. Same symptoms and problems:

hda: timeout waiting for DMA
ide_dmaproc: chipset supported ide_dma_timeout func only: 14
hda: irq timeout: status=0x58 { DriveReady SeekComplete DataRequest }
...
hda: DMA disabled
ide0: reset: success

The 3Com on-board Ethernet is also again broken in the same way (i.e. after a
warm boot).

All standard wolverine RPMS are in use (incl. 2.4.1-0.1.9 kernel). After having
success with 2.4.1-0.1.9 on-top of fisher, things broke after I upgraded to
wolverine (over the top).  A fresh wolverine installation again didn't help.





Comment 13 Michael K. Johnson 2001-02-23 19:40:18 UTC
Well, 2.4.1-0.1.9 is 2.4.1-0.1.9 whether you have the fisher or
wolverine rpms underneath it.  Want to try 0.1.14?

Which ethernet driver (two drivers claim to support your card) are
you using?

Comment 14 David Sainty 2001-02-23 20:30:55 UTC
I also cannot explain why it would have worked back with fisher!  I have just
tried 0.1.14 kernel and still no luck. I am going back to fisher w/ 2.4.1-0.1.9
to make sure this is repeatable, and its not something else.



Comment 15 Bill Nottingham 2001-02-23 20:35:12 UTC
Could it possibly depend on how the previous kernel rebooted
(real-mode, 32-bit, etc.)?

Comment 16 Michael K. Johnson 2001-02-23 20:49:58 UTC
Good point, try with apm=realmode and see if it fixes the problem.

Comment 17 David Sainty 2001-03-10 19:35:58 UTC
Sorry for the delay Michael.

I have tried more recent kernels - 2.4.2-0.1.19 and 2.4.2-0.1.22 and all seems
good at the moment. The base upon which I'm running these kernels is wolverine
with all RPMS upgraded to rawhide-20010303.

Comment 18 Michael K. Johnson 2001-03-13 04:34:25 UTC
OK, we'll count this as fixed in rawhide.

Comment 19 David Sainty 2001-04-08 15:18:16 UTC
Unfortunately guys, its baaaaack.

kernel-2.4.2-0.1.49 and 2.4.2-0.1.51 are misbehaving wrt this.

Exactly the same as before. Basically you CANNOT warm reboot w/ these kernels.

1. NIC i/f dies.
2. IDE DMA plays up:

hda: timeout waiting for DMA
ide_dmaproc: chipset supported ide_dma_timeout func only: 14
hda: irq timeout: status = 0x58 { DriveReady SeekComplete DataRequest }
hda: DMA disabled
<loops numerous times>
ide0: reset success.


Comment 20 Alan Cox 2003-06-09 14:55:11 UTC
Please reopem if present in the new 2.4.20 ide
Thanks



Note You need to log in before you can comment on or make changes to this bug.