Bug 26214 - up2date fails on headless RH7 w/o x
up2date fails on headless RH7 w/o x
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-05 16:08 EST by Need Real Name
Modified: 2015-01-07 18:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-19 20:33:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-05 16:08:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.5 [en] (WinNT; U)


System - Dell PowerEdge 1400
Headless - boots to console
X - not installed - all services must be run from command line
OS - RH7.0


Reproducible: Always
Steps to Reproduce:
1.up2date -r -l  system hangs and finally gives a "time out" error message
2.up2date -l system spews error messages and process quits
3.up2date -d system spews error messages and process quits
I found some info stating that there were problems running up2date from SSH.  I have tried this from SSH and telnet.  I cannot run this from the 
machine directly as it is "headless" and included in our server farm.  
	

Actual Results:  1.  system hangs and does nothing until manually interrupted or returns There was a fatal error communicating with the 
server.  
The message was:
Connection timed out
2. You are not registered with Red Hat Network.  To use Update Agent,
You must be registered.

However, you can continue now with an anonymous registration, and only
your Red Hat Linux version and computer architecture will be sent to
redhat.com.  You are free to use the rhn_register later to take full
advantage of the benefits offered by the Red Hat Network.

To register anonymously, specify "--register" as a command line option.

Retrieving list of all available packages...
Traceback (innermost last):
  File "/usr/sbin/up2date", line 382, in ?
    main()
  File "/usr/sbin/up2date", line 366, in main
    sys.exit(batchRun(onlyList, pkgNames))
  File "/usr/sbin/up2date", line 138, in batchRun
    updated, skipped = up2date.getUpdatedPackageList(printit, percent)
  File "/usr/share/rhn/up2date/up2date.py", line 872, in getUpdatedPackageList
    pkgList = getAvailablePackageList()
  File "/usr/share/rhn/up2date/up2date.py", line 267, in getAvailablePackageList
    availPkgList = s.up2date.listall(getSystemId())
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 576, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 602, in __request
    request = dumps(params, methodname)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 470, in dumps
    data = m.dumps(params)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 246, in dumps
    self.__dump(v)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 257, in __dump
    raise TypeError, "cannot marshal %s objects" % type(value)
TypeError: cannot marshal <type 'None'> objects
3.Traceback (innermost last):
  File "/usr/sbin/up2date", line 382, in ?
    main()
  File "/usr/sbin/up2date", line 263, in main
    print "Error parsing command line arguments: %s" % msg
NameError: msg

Expected Results:  According to the documents I have found it should have registered me and given me a list of available updates or just 
downloaded the available updates depending on the option flags used.  

Your documentation is located at http://www.redhat.com/support/manuals/RHNetwork/ref-guide/text-up2date.html and I have been unable to 
get 
up2date to do anything at all.  I don't understand what is going wrong, because it should be working.
Comment 1 Preston Brown 2001-02-08 22:37:16 EST
1. The up2date server was down temporarily.  This accounts for your connection
refused errors.

2. The problems with anonymous registration are fixed with up2date 2.1.7,
available at updates.redhat.com.  We recommend that you upgrade as indicated at
http://www.redhat.com/errata.

3. Anonymous registration is not nearly as useful as a real RHN registration. 
Use the "rhn_register" program to complete registration.
Comment 2 Need Real Name 2001-02-09 12:11:08 EST
I have applied the patches you recommened even though I had to use --force to get them to install.  I am still having the same problem.  I have an 
identical machine as my development workstation which has x installed and it works perfectly.  In fact, it's updating as we speak.  For some reason 
up2date seems to depend on X in a headless install.  Both boxes are accessable via console and ssh.  I can forward the x via ssh and up2date works 
fine.  However, it still doesn't connect with you folks on the box WITHOUT x.  That is the ONLY difference between the 2 boxes.  They have been kept 
identical on purpose.
Comment 3 Need Real Name 2001-02-09 12:42:47 EST
I forgot to add that rhn_register doesn't work either.  I know that it's not a problem with my network connectivity because I can use this server to telnet, 
ssh, ftp, etc. in to box on my network and out on the internet.  I should probably also mention that most unnecssary RPM's were uninstalled and if you 
like I can send you a spreadsheet showing you what is still active.
Comment 4 Adrian Likins 2001-02-14 00:47:42 EST
The next versions of up2date include a `--nox` option, that will
tell the client not to attempt to use X regardless of the
setting of DISPLAY, or otherwise.

This option is available for `up2date`, and `rhn_register`,
so it should solve this problem. There is also better
handling of the cases where it looks like everything is
setup for the use of X, but attaching to the X server
fails (ie, a bogus DISPLAY setting is a good example).
Comment 5 Cristian Gafton 2001-02-19 20:33:20 EST
Assigned QA to jturner
Comment 6 Preston Brown 2001-02-26 18:56:13 EST
if your DISPLAY variable is set, up2date, rhn_register, and other programs
(emacs) that support X will believe it and try to work with X.  If you don't
actually have X installed, then you should make sure that this variable is
unset.

You can use the --nox option available in the rawhide version as well; we will
be releasing official stable errata shortly that includes this option.  Until
then, make sure your DISPLAY variable is not set.
Comment 7 Jay Turner 2001-03-07 14:35:40 EST
Code in CVS right now which makes this process a lot less painful.  Am able to
ssh into a machine which does not have X of any sort installed, and then issue
up2date command line without any problems.
Comment 8 Jay Turner 2001-03-07 15:49:32 EST
Code in CVS right now which makes this process a lot less painful.  Am able to
ssh into a machine which does not have X of any sort installed, and then issue
up2date command line without any problems.

Note You need to log in before you can comment on or make changes to this bug.