Bug 262161 - /bin/sh: uncompress: command not found
/bin/sh: uncompress: command not found
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
i686 All
medium Severity low
: ---
: ---
Assigned To: Chip Coldwell
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-08-28 20:50 EDT by Aaron S. Hawley
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-09-14 11:29:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Patch against jka-cmp-hook.el.diff (661 bytes, patch)
2007-08-28 20:50 EDT, Aaron S. Hawley
no flags Details | Diff
Revised patch to jka-cmp-hook.el (522 bytes, patch)
2007-09-07 11:53 EDT, Aaron S. Hawley
no flags Details | Diff

  None (edit)
Description Aaron S. Hawley 2007-08-28 20:50:46 EDT
Description of problem:

Version-Release number of selected component (if applicable):

GNU Emacs 22.1.1 (i386-redhat-linux-gnu, GTK+ Version 2.10.8) of 2007-06-26 on

How reproducible:

Steps to Reproduce:
1. Download and open in Emacs the compressed Emacs lisp file specified by the URL.
Actual results:

Error while executing "uncompress -c < /home/aaronh/Desktop/unique.el.Z"

/bin/sh: uncompress: command not found

Expected results:

File should be uncompressed with `gzip -d -c -q', since `compress' and
`uncompress' are not installed by default or as dependencies.

Additional info:

Glad to see the Emacs icon in the Emacs-22.1 package!  It didn't show up with
the Emacs-22.0.99 package.
Comment 1 Aaron S. Hawley 2007-08-28 20:50:46 EDT
Created attachment 177701 [details]
Patch against jka-cmp-hook.el.diff
Comment 2 Aaron S. Hawley 2007-09-07 11:53:18 EDT
Created attachment 190081 [details]
Revised patch to jka-cmp-hook.el

My first patch was a bit ignorant.  Gzip can uncompress compressed files (.Z),
but I didn't actually think about (or test) whether gzip can create a
compressed file -- compatible with the compress command.  I now know that was
an oversight.

The new patch now uses gzip as an alternative to uncompress, but *not* for
compress.  So, saving a .Z file in Emacs will now generate the error "/bin/sh:
compress: command not found".  So still a bit buggy, but I argue that we should
enable users to open compress-ed files in Emacs, rather than not at all.  If
they have trouble writing compressed files, then they should install the
ncompress package.  More than likely, they should be compressing the file to
the gzip or bzip2 format -- or compression may not be paramount, anyway. 
However, we can generally be assured gzip is installed, so let's use it here!

If you'd rather see this upstream, I'm willing to help.
Comment 3 Tom Tromey 2007-09-09 01:37:43 EDT
Yeah, IMO sending this upstream would be best.
Simplest is M-x report-emacs-bug, then include the patch.
Comment 4 Aaron S. Hawley 2007-09-10 15:40:30 EDT
Done.  We'll see if it's accepted.

Comment 5 Aaron S. Hawley 2007-09-14 11:29:53 EDT
Resolved upstream.

Commited to trunk:


Note You need to log in before you can comment on or make changes to this bug.