Bug 26233 - Boot hangs if no Zip Disk in Internal Zip Drive
Summary: Boot hangs if no Zip Disk in Internal Zip Drive
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Doug Ledford
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-05 22:22 UTC by Need Real Name
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-09 14:56:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-02-05 22:22:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; SunOS 5.6 sun4u)


I have a machine with 1GHz Athlon, 45MB hdd, a 40x CD-rom, and Zip drive.

P.Master:	HDD
P.Slave:	Zip Drive
S.Master:	CD-ROM

If I boot the machine without a zip disk in the drive, I get:
hda: [drive specs]
hdb: [long pause, then] lost interrupt
lost interrupt
lost interrupt
lost interrupt
.
.
.

This goes on until I give up and either:
a) put in a zip disk and reboot, or
b) power down, remove the zip drive, and power back up.

The system boots quite happily if there is a disk in the drive.

[Sorry if this is a dup, I couldn't find any other bug report that matched
it....]



Reproducible: Always
Steps to Reproduce:
1.  Make sure there is no zip disk in internal zip drive
2.  Power up the machine
3.  Wait.  The machine will hang as described above.

	

Actual Results:  See description section above.

Expected Results:  The system should boot quite happily whether there is a
disk in the zip drive, or not.  RH5.2 booted as expected.  I don't recall,
but I believe 6.2, acted like 7.0.

This is rather annoying.  If you can provide some insights on how to track
it down, I don't mind being a guinea pig.

Comment 1 Curtis Doty 2001-02-23 02:17:27 UTC
Confirmed same symptoms on fisher. Need zip disk in drive to bypass.

Test platform is a Micron Millennia Pro2 (P2/200). borgan, johnsonm, I've no 
idea how to link this bug into the fisher project. Sorry.

Comment 2 Michael K. Johnson 2001-02-23 18:10:45 UTC
Doug, could this be hanging in lun probing?  If so, can you add this
to the lun probe blacklist?

Comment 3 Paul Raines 2002-02-06 18:16:40 UTC
I believe this behavior is due to a particular version of the zip drive.
I have nearly identical systems running the same kernel, but one hangs and
one doesn't if there is no zip in the drive.  If I swap drives, the behavior
follows the drive.  THe drive works fine in Windows so there is obviously
some solution to this

Comment 4 Alan Cox 2003-06-09 14:56:24 UTC
Should work in 2.4.18 and higher reliably. If not please re-open


Note You need to log in before you can comment on or make changes to this bug.