Bug 26250 - ntptimeset generates errors
ntptimeset generates errors
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ntp (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-05 17:54 EST by Jaroslaw Sosnicki
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-05 17:54:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslaw Sosnicki 2001-02-05 17:54:56 EST
I am trying to synchronize time to external server using ntptimeset 
command part of ntp package and I ame getting the flowing errors:
[root@ns1 RPMS]# ntptimeset
 5 Feb 18:53:59 ntptimeset[4177]: getnetnum: "time.nist.gov" invalid host 
number
, line ignored
 5 Feb 18:53:59 ntptimeset[4177]: getnetnum: "clepsydra.dec.com" invalid 
host nu
mber, line ignored
 5 Feb 18:53:59 ntptimeset[4177]: getnetnum: "clock1.unc.edu" invalid host 
numbe
r, line ignored
 5 Feb 18:53:59 ntptimeset[4177]: getnetnum: "ncar.ucar.edu" invalid host 
number
, line ignored
 5 Feb 18:53:59 ntptimeset[4177]: Found 0 servers, require 3 servers
[root@ns1 RPMS]#

Here is an info about my setup:

[root@ns1 RPMS]# rpm -q ntp adjtimex
ntp-4.0.99k-5
adjtimex-1.11-4

My setup ntp setup file default with additiona of 4 ntp time servers
[[root@ns1 RPMS]# cat /etc/ntp.conf

#
# Undisciplined Local Clock. This is a fake driver intended for backup
# and when no outside source of synchronized time is available. The
# default stratum is usually 3, but in this case we elect to use stratum
# 0. Since the server line does not have the prefer keyword, this driver
# is never used for synchronization, unless no other other
# synchronization source is available. In case the local host is
# controlled by some external source, such as an external oscillator or
# another protocol, the prefer keyword would cause the local host to
# disregard all other synchronization sources, unless the kernel
# modifications are in use and declare an unsynchronized condition.
#
#server 127.127.1.0     # local clock
#fudge  127.127.1.0 stratum 10

server time.nist.gov
server clepsydra.dec.com
server clock1.unc.edu
server ncar.ucar.edu

#
# Drift file.  Put this in a directory which the daemon can write to.
# No symbolic links allowed, either, since the daemon updates the file
# by creating a temporary in the same directory and then rename()'ing
# it to the file.
#
driftfile /etc/ntp/drift
multicastclient                 # listen on default 224.0.1.1
broadcastdelay  0.008

#
# Authentication delay.  If you use, or plan to use someday, the
# authentication facility you should make the programs in the auth_stuff
# directory and figure out what this number should be on your machine.
#
authenticate no

#
# Keys file.  If you want to diddle your server at run time, make a
# keys file (mode 600 for sure) and define the key number to be
# used for making requests.
#
# PLEASE DO NOT USE THE DEFAULT VALUES HERE. Pick your own, or remote
# systems might be able to reset your clock at will. Note also that
# ntpd is started with a -A flag, disabling authentication, that
# will have to be removed as well.
#
#keys           /etc/ntp/keys
[root@ns1 RPMS]#
Comment 1 Preston Brown 2001-02-06 16:05:01 EST
fixed in 4.0.99k-8 and later.

Note You need to log in before you can comment on or make changes to this bug.