Bug 262721 - package update does not work
package update does not work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gchempaint (Show other bugs)
7
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Julian Sikorski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-29 04:05 EDT by Robert Greimel
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-05 13:13:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
yum error for package update (4.11 KB, text/plain)
2007-08-29 04:05 EDT, Robert Greimel
no flags Details

  None (edit)
Description Robert Greimel 2007-08-29 04:05:43 EDT
Description of problem:
update of gchempaint using yum fails

Version-Release number of selected component (if applicable):
0.6.9-1.fc7 (installed), 0.8.2-2.fc7 (to be installed)

How reproducible:
always

Steps to Reproduce:
1.yum update gchempaint
2.
3.
  
Actual results:
Error, see attached file

Expected results:
update of package

Additional info:
A workaround is

yum remove gchempaint
Removing:
 gchempaint              i386       0.6.9-1.fc7      installed         2.0 M
 gchempaint              x86_64     0.6.9-1.fc7      installed         2.1 M

yum install gchempaint
Installing:
 gchempaint              i386       0.6.9-1.fc7      fedora            955 k
 gchempaint              x86_64     0.8.2-2.fc7      updates           1.4 M
Installing for dependencies:
 goffice04               x86_64     0.4.2-1.fc7      updates           1.5 M
 libgsf-gnome            x86_64     1.14.3-4.fc7     fedora             14 k

Interestingly this shows that the i386 package is not updated to the newest
version. Maybe that is the problem ?
Further yum install gchempaint output:

Running Transaction
  Installing: libgsf-gnome                 ######################### [1/4] 
  Installing: goffice04                    ######################### [2/4] 
  Installing: gchempaint                   ######################### [3/4] 
gconfd-2: no process killed
gconfd-2: no process killed
I/O warning : failed to load external entity "/etc/gconf/schemas/gchempaint.schemas"
Failed to open `/etc/gconf/schemas/gchempaint.schemas': No such file or directory
gconfd-2: no process killed
  Installing: gchempaint                   ######################### [4/4] 
gconfd-2: no process killed
gconfd-2: no process killed
Comment 1 Robert Greimel 2007-08-29 04:05:43 EDT
Created attachment 178321 [details]
yum error for package update
Comment 2 Julian Sikorski 2007-08-29 05:42:14 EDT
Hmm, yep. The problem is caused by the fact that 0.6.9 is multilib, while 0.8.2
is not, hence the conflicts. I'll investigate.
Comment 3 Julian Sikorski 2007-09-03 09:12:53 EDT
There is a simpler way to do that. Just run yum erase gchempaint.i386 prior to
the  update, that should do it. IMHO, yum shouldn't pull i386 arch of a package
unless asked, that way such problems would be avoided.
Comment 4 Robert Greimel 2007-09-03 09:29:36 EDT
(In reply to comment #3)
> There is a simpler way to do that. Just run yum erase gchempaint.i386 prior to
> the  update, that should do it. IMHO, yum shouldn't pull i386 arch of a package
> unless asked, that way such problems would be avoided.

OK. Just note that at no point did I ask yum to install the i386 version. It did
this at the initial install (which either was at Fedora install time or right
afterwards using the package manager - I don't remember) and also when I
re-installed it.
Comment 5 Julian Sikorski 2007-09-03 10:08:47 EDT
Agreed. Yum installs every single arch of a package by default. Such decision
was made by yum devs.

Note You need to log in before you can comment on or make changes to this bug.