Bug 262861 - exportfs does not synchronize xtab with exports file
exportfs does not synchronize xtab with exports file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
7
other Linux
medium Severity low
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-29 06:27 EDT by Mijo Safradin
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 1.1.0-4.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-29 15:02:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Purposed patch (3.24 KB, text/x-patch)
2007-09-14 13:37 EDT, Steve Dickson
no flags Details

  None (edit)
Description Mijo Safradin 2007-08-29 06:27:12 EDT
Description of problem:
Running "exportfs -av" or "exportfs -rv" does not synchronize /var/lib/nfs/xtab
with /etc/exports as it should according to the man page of exportfs.

The xtab remains always empty.

Version-Release number of selected component (if applicable):
$ rpm -qa | grep nfs
nfs-utils-lib-1.0.8-8.fc7
nfs-utils-1.0.12-4.fc7

How reproducible:

Steps to Reproduce:
1. export directory (/etc/export)
2. mount direcotry (other machine)
3. run exportfs
  
Actual results:
$ cat /etc/exports 
/M_EXPORT *(rw,sync,root_squash)
$ /etc/init.d/nfs restart
Shutting down NFS mountd:                                  [  OK  ]
Shutting down NFS daemon:                                  [  OK  ]
Shutting down NFS quotas:                                  [  OK  ]
Shutting down NFS services:                                [  OK  ]
Starting NFS services:                                     [  OK  ]
Starting NFS quotas:                                       [  OK  ]
Starting NFS daemon:                                       [  OK  ]
Starting NFS mountd:                                       [  OK  ]
$ exportfs -rv
exporting *:/M_EXPORT
$ echo $?
0
$ cat /var/lib/nfs/xtab
$

xtab is empty ..

Expected results:
cat /var/lib/nfs/xtab
... some conent about exported nfs directories

Additional info:
I red the man page of exportfs. From this I would expect some content for the
xtab file. Is this file simply not used anymore? If so, then a change of the
man page would be needed.

I searched also for other bugzillas about this problem, and I found only one ... 
that mentioned this behavior at one comment. See bugzilla #165346 Comment #6.
Comment 1 Steve Dickson 2007-09-14 13:37:04 EDT
Created attachment 196031 [details]
Purposed patch

Interesting... It turns out that when a new style of in-kernel
caching was added to both exportfs and mountd, the /var/lib/nfs/xtab
file is no longer used. The /var/lib/nfs/etab now the where 
the export information is kept. 

I've sent the attached patch to the maintainers for comment.
Comment 2 Fedora Update System 2007-09-18 18:31:18 EDT
nfs-utils-1.1.0-4.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Fedora Update System 2007-10-29 15:02:22 EDT
nfs-utils-1.1.0-4.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.