Bug 26291 - Mismatch /var/lock/subsys/powertweak and /etc/init.d/powertweakd
Summary: Mismatch /var/lock/subsys/powertweak and /etc/init.d/powertweakd
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: powertweak   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard: Florence Gold
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-06 10:08 UTC by Walter Mueller
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-07 09:37:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Walter Mueller 2001-02-06 10:08:45 UTC
shutdown shows the message

/etc/rc6.d/killall /etc/init.d/powertweak no such file or directory

This is because the file in /etc/init.d is called powertweakd but the 
execution of  /etc/init.d/pvmd touches the file /var/lock/subsys/powertweak

killall strips the directory part from the entry in
/var/lock/subsys/powertweak and
tries execute the file in /etc/init.d/powertweak which does not exist

Comment 1 Glen Foster 2001-02-07 00:20:15 UTC
We (Red Hat) should really try to fix this before next release.

Comment 2 Tim Powers 2001-02-12 22:05:14 UTC
OK. This is fixed in the powertweak-0.99.0-5 derived packages.  It has been
fixed by having the initscript touch /var/lock/subsys/powertweakd instead of 
/var/lock/subsys/powertweak.

Thanks for the heads up.

Tim


Note You need to log in before you can comment on or make changes to this bug.