Bug 26312 - ONBOOT=no is not working
ONBOOT=no is not working
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: hotplug (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
: 28191 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-06 11:13 EST by Florian La Roche
Modified: 2007-04-18 12:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-25 17:21:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2001-02-06 11:13:53 EST
I have initscripts 5.61.1 installed and with
ONBOOT=no, networking on eth0 is still started
on bootup
Comment 1 Bill Nottingham 2001-02-06 12:56:11 EST
Is it pcmcia?
Comment 2 Bill Nottingham 2001-02-06 13:09:57 EST
hotplug is being nice enough to load it for you. Bleah.
Comment 3 Trond Eivind Glomsrxd 2001-02-06 13:17:06 EST
Standard PCI network interface?
Comment 4 Bill Nottingham 2001-02-06 17:51:21 EST
Yup. I just reproduced it here; basically, if you have ONBOOT=no and
you boot an entire system, *something*  triggers a hotplug event that
loads the driver.
Comment 5 Trond Eivind Glomsrxd 2001-02-12 15:34:16 EST
Please try the freshest Rawhide, I can't reproduce this with such a system - I
had to manually ifup the interface (and restart autofs, as I discovered later)
Comment 6 Florian La Roche 2001-02-13 11:04:25 EST
Happens for me with a normal machine with dhcp and ONBOOT=no with
the current rpms as of 5 minutes ago. No pcmcia in this computer.


Comment 7 Trond Eivind Glomsrxd 2001-02-15 19:59:21 EST
Still happens with hotplug-2001_02_14-3. Need to look more into this.
Comment 8 Trond Eivind Glomsrxd 2001-02-16 14:32:02 EST
When a module is loaded, the kernel asks hotplug to initialize it and it does
what it's told.
Comment 9 Trond Eivind Glomsrxd 2001-02-16 15:39:24 EST
hotplugging should be turned off when the initscript loads the modules - it does
so to preserve ordering, and this obiviously calls hotplug.
Comment 10 Bill Nottingham 2001-02-16 15:46:24 EST
Actually, the more I think about it, the fact that hotplug
triggers for every interface creation, regardless of cause,
is fundamentally broken.

We should just remove the package until it's done right, or fix
it. It's like hacking the initscripts to work around linuxconf
being a pile of dung.
Comment 11 Bill Nottingham 2001-02-16 15:49:04 EST
In short: interface creation does not, and *should not*, imply that
you want to bring up the interface, regardless of device type.
Comment 12 Trond Eivind Glomsrxd 2001-02-16 15:54:51 EST
That would be kernel related... and we would to make it continue working when
plugging in a new device, like USB ethernet.
Comment 13 Bill Nottingham 2001-02-17 22:19:27 EST
*** Bug 28191 has been marked as a duplicate of this bug. ***
Comment 14 Bill Nottingham 2001-02-25 17:21:24 EST
That is not a kernel problem. hotplug gets all the events, and it needs to
have the brains to know what to do with them (and be more configurable
in this regard.)

Policy goes in userspace, not in kernel space.
Comment 15 Trond Eivind Glomsrxd 2001-02-27 17:11:57 EST
This should be fixed in initscripts-5.67-1.

Note You need to log in before you can comment on or make changes to this bug.