Bug 2633 - Linuxconf messes up with samba?
Linuxconf messes up with samba?
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
: 2696 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-07 09:03 EDT by stef.pillaert
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-03 18:52:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stef.pillaert 1999-05-07 09:03:32 EDT
(installed RedHat 6.0 on a i386)
Hello,
I tried to change the samba workgroup (from MYGROUP to
BOUWKUNDE) using Linuxconf. It seemed that Linuxconf messed
up my smb.conf file, leaving funny characters where the
group should be mentioned.

I removed samba (with rpm -e) and reinstalled (with rpm).

If I click on samba (in Linuxconf) now, I get the input-box
for sendmail settings, not the one for samba settings!!!

Very weird things going on..

Stef.
Comment 1 Michael K. Johnson 1999-05-11 14:38:59 EDT
Added Jacques to CC line.

Jacques, any chance that treemenu isn't always recognizing when it
needs to be recalculated?  Our linuxconf package has triggers for
when samba is installed/uninstalled (among other packages) as you
suggested.

The workaround in the meantime should be (as root):
rm -f /var/run/treemenu.cache
Comment 2 glenn 1999-06-30 08:55:59 EDT
I've seen part of this, too.  After a fresh install of 6.0, if Samba
is deleted, and then re-installed, access of Samba (e.g., the
'defaults' item) shows you screens for sendmail.

The problem is related to the /etc/conf.linuxconf file.  Removing the
Samba RPM and then re-installing it changes the order of the lines
for samba and mailconf.  Editing the file and reversing the order
(samba before mailconf) restores linuxconf operation to normal.

Gnome documentation linuxconf indicates that if standard utilites are
used to access the conf.linuxconf file, fetches of key/value pairs
will be order independent (a Good Thing!).

The faulty behavior of linuxconf can be easily demonstrated by editing
the file, and changing the order of the samba/mailconf lines.

Oddly, invoking linuxconf as 'netconf' gets you access to all the
right stuff.
Comment 3 Derek Tattersall 1999-08-03 12:01:59 EDT
*** Bug 2696 has been marked as a duplicate of this bug. ***

When using linuxconf on 6.0 to setup smb.conf binary data
get put into the file and becomes unusable ...
Comment 4 Michael K. Johnson 1999-08-03 18:52:59 EDT
Reported fixed in linuxconf-1.16r1.3, released as update RHEA-1999:026

Note You need to log in before you can comment on or make changes to this bug.