Bug 26349 - /etc/profile.d/lang.sh now causes permission denied error when using su
/etc/profile.d/lang.sh now causes permission denied error when using su
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-06 14:25 EST by David Sainty
Modified: 2014-03-16 22:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-06 14:25:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Sainty 2001-02-06 14:25:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-9 i686)


When you su as root, to another user, you get a permission denied error
like:

bash: /proc/19164/fd/0: Permission denied

This is caused by the execution of /etc/profile.d/lang.sh.  Subsequent
executions of bash as this user continue to give the error.

Reproducible: Always
Steps to Reproduce:
1.Install Fisher
2."useradd username && passwd username"
3."su username"
	

Actual Results:  Although not causing grave consequences (that I know of),
you get Permission denied errors which will scare some users.

Expected Results:  There should be no errors.
Comment 1 Bill Nottingham 2001-02-06 16:34:39 EST
Will be fixed in 5.62-1.

Note You need to log in before you can comment on or make changes to this bug.