Bug 2636 - (alpha) xfig isn't able to draw some objects
(alpha) xfig isn't able to draw some objects
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: xfig (Show other bugs)
6.0
alpha Linux
medium Severity high
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-07 12:16 EDT by hvr
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-30 15:19:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hvr 1999-05-07 12:16:17 EDT
xfig fails drawing polygons, rectangular boxes, polylines,
etc.. on alpha architecture
Comment 1 Preston Brown 1999-08-30 14:24:59 EDT
it appears that xfig isn't 64 bit clean at all.  I'm working on it.
Comment 2 Preston Brown 1999-08-30 15:19:59 EDT
XFig is a mess.  There are tons and tons of casts from XtPointers to
int type.  On intel and 32-bit sparc, this is fine, but it is very bad
on the alpha.

We suggest that you get in contact with the author of the program and
tell him the problem, but we can't make fixing this a priority here,
as xfig is largely being supplanted by newer programs from GNOME and
KDE at this point, and the fixes will be non-trivial.

Note You need to log in before you can comment on or make changes to this bug.