Bug 26369 - -F does not catch the dependencies.
Summary: -F does not catch the dependencies.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-06 22:22 UTC by Need Real Name
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-06 22:26:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-02-06 22:22:22 UTC
The -F option does not catch the
dependices even if the package is in the arguments list.
For example:
the following command does not work
when doing RedHat 7.0 update:

rpm -Uvh glibc-2.2-12.i386.rpm glibc-common-2.2-12.i386.rpm
glibc-devel-2.2-12.i386.rpm glibc-profile-2.2-12.i386.rpm
nscd-2.2-12.i386.rpm

it prints that the package glibc-common required.

Comment 1 Need Real Name 2001-02-06 22:26:42 UTC
I meant rpm -Fvh , not rpm -Uvh as in the example above.

Comment 2 Jeff Johnson 2001-02-06 22:28:21 UTC
The semantics of -F --freshen are
	Install package from command line only if package is already installed.
Since glibc-common is not installed, the package is skipped. This is exactly how
--freshen is supposed to work.


Note You need to log in before you can comment on or make changes to this bug.