Bug 26372 - MySQL fails to shutdown after password assigned
Summary: MySQL fails to shutdown after password assigned
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mysql   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Patrick Macdonald
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-06 22:52 UTC by mcisar
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-06 22:52:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mcisar 2001-02-06 22:52:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


Running MySQL 3.32.32-1.7  After using the mysqladmin password command to 
secure the mysql installation with a database administrator password the   
service mysql stop  command fails to shutdown the mysql server.  I believe 
this is due to the fact that the init script uses the mysqladmin command 
to attempt to gracefully shutdown the database subsystem, but once a 
database administrator password has been set, mysqladmin must be provided 
with that password in order to execute the shutdown

Reproducible: Always
Steps to Reproduce:
1. use  mysqladmin password newpassword  to secure your mysql installation
2. attempt to shutdown mysql with   service mysql stop
	

Actual Results:  database subsystem will not shut down 

Expected Results:  database subsystem should have shut down

Although it hasn't happened to me yet, loss of data could occur if the 
database subsystem doesn't cleanly shut down when machine is being 
rebooted or powered off.

Comment 1 Trond Eivind Glomsrxd 2001-02-06 22:57:19 UTC
The database system will always shut down when given a kill signal, which the
shutdown will do... to work around it: Configure authentication in /root/.my.cnf
or upgrade to mysql-3.23.32-5 from Rawhide, which uses a different shutdown
mechanism.

Comment 2 Need Real Name 2001-03-14 19:08:55 UTC
Please excuse my ignorance, but I am having the same problem. Documentation on your 
"workaround" of using my.cnf are slime to none so I can not seem to get that approach working.
I also used "up2date" to check for an update to the mysql 3.23.32-1.7 I am running and nothing
was reported. I then fired up gnorpm and found nothing more current than that version as well.
Any additional info would be greatly appreciated.


Note You need to log in before you can comment on or make changes to this bug.