Bug 26380 - quotacheck -a doesn't set up quota.group database
quotacheck -a doesn't set up quota.group database
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: quota (Show other bugs)
7.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Preston Brown
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-06 19:30 EST by Steve Bonneville
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-06 19:30:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Bonneville 2001-02-06 19:30:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-22 i686)


According to the quotacheck(8) man page, "quotacheck -a" should check both
user and group quotas for the filesystems mentioned in /etc/fstab. 
Actually, it only checks USER quotas.  It turns out that to set up group
quotas with the -a option, you also need to specify the -g option (contrary
to the documentation).

Reproducible: Always
Steps to Reproduce:
Assume we have a /home partition:
1.  Set usrquota,grpquota mount options for /home in /etc/fstab. 
2.  `mount -o remount /home` 
3.  quotacheck -a
	

Actual Results:  A /home/quota.user file is created, but no
/home/quota.group file is created.  If both files exist, only
/home/quota.user is updated.

Expected Results:  According to the man page, both /home/quota.user and
/home/quota.group should be created or updated accordingly.  

By default just using `quotacheck` implies `quotacheck -u`, and this is
correctly documented.  However, it's clear from the man page that
`quotacheck -a` is supposed to imply the same behavior currently exhibited
by `quotacheck -a -g -u`.

Quotes from quotacheck(8):

> OPTIONS
> [...]
>       -u     This flag tells the program to scan the disk and to
>              count the files and directories used by  a  certain
>              uid. This is the default action.
>
>       -g     This flag forces the program to count the the files
>              and directories used by a certain gid.
>
>       -a     Check all of the quotas for  the  filesystems  men-
>              tioned  in  /etc/fstab.  Both user and group quotas
>              are  checked  as  indictated  by   the   /etc/fstab
>              options.

This bug can probably be resolved either by changing the man page or by
changing quotacheck.  :)
Comment 1 Preston Brown 2001-02-07 13:47:02 EST
fixed in quota-2.00-2 and later by changing man page.

Note You need to log in before you can comment on or make changes to this bug.