Bug 264 - vixie-cron and ypbind starting order should be reversed
vixie-cron and ypbind starting order should be reversed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: ypbind (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 837 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-02 12:52 EST by w.wouts
Modified: 2014-03-16 22:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-22 12:15:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description w.wouts 1998-12-02 12:52:49 EST
Default crond is started before ypbind. This is a problem,
because crond will not accept jobs from users which it
doesn't know. And of course a lot of users won't be 'known'
until ypbind has been started.

Should be easy enough to fix, but it is quite annoying...

Regards
Ward Wouts
Comment 1 Jeff Johnson 1999-01-15 11:06:59 EST
*** Bug 264 has been marked as a duplicate of this bug. ***

The default start and stop orders for the NIS daemons are
wrong.

cd /etc/rc.d/init.d
grep chkconfig yp*

ypbind:# chkconfig: - 13 87
yppasswdd:# chkconfig: - 66 34
ypserv:# chkconfig: - 65 35

ypbind is started before and stopped after ypserv but ypbind
depends on ypserv.

This makes it difficult to run NIS clients on the same
machine as an NIS server (to for example use netgroups).

What is the best solution to this problem?  I had thought of
changing the initscripts to change the start and stop order
but I think this might have hidden dependencies with other
packages.

------- Additional Comments From landrye@capital.ous.edu  01/15/99 00:58 -------
See also bug 264

URL: http://developer.redhat.com/bugzilla/show_bug.cgi?id=264
Comment 2 w.wouts 1999-01-16 11:09:59 EST
I think nfsfs should be started after ypbind too. When you have a
setup without a nameserver but with NIS you probably want to use NIS
to distribute hostnames. Mounting of nfsfs will fail on boot if you
have this setup and want to use hostnames in /etc/fstab
Comment 3 Preston Brown 1999-03-22 12:03:59 EST
bill: you want to futz with these?
Comment 4 Bill Nottingham 1999-03-22 12:11:59 EST
this has been fixed in 5.9; the
current starting order is:

network
portmap
ypbind
nfsfs
random
nscd
syslog
atd
crond
...
Comment 5 Bill Nottingham 1999-03-22 12:15:59 EST
make that:
network
portmap
ypserv
ypbind
nfsfs
...

Note You need to log in before you can comment on or make changes to this bug.