Bug 2643 - IMAP Inbox file lock error.
IMAP Inbox file lock error.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-07 18:23 EDT by Joseph Kotran
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-23 17:22:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Kotran 1999-05-07 18:23:50 EDT
Hello,

	The Red Hat 6.0 distributed version of Netscape
Communicator 4.51 does not handle file locks on the IMAP
mail Inbox properly.  When accessing an IMAP server the mail
client hangs when accessing Inbox.  In the status line at
the bottom of the mail client it indicates that it is
waiting for a connection to the Inbox.

	This behavior is not present in the Netscape distribution
of Communicator 4.51.
Comment 1 Bill Nottingham 1999-05-10 12:38:59 EDT
Works OK for me here. How are the IMAP folders stored on
the server?
Comment 2 Joseph Kotran 1999-05-10 12:52:59 EDT
The IMAP folders are located in the user's home directory.  They work
as expected.  However, the Inbox is in /var/mail on a Solaris 2.6
server.  The Inbox access is what hangs.  The IMAP server is the
University of Washington daemon.  We have the same problem with Sun's
IMAP daemon too.
Comment 3 Bill Nottingham 1999-05-10 14:28:59 EDT
Is lockd running on the machine that's doing the NFS mounting
of /var/mail?
Comment 4 Joseph Kotran 1999-05-10 14:33:59 EDT
Yes, the lockd daemon is running.
Comment 5 Bill Nottingham 1999-05-10 15:53:59 EDT
What happens if you mount the /var/mail partition with the 'nolock'
option?
Comment 6 Bill Nottingham 1999-06-23 17:22:59 EDT
closed due to lack of input.

Note You need to log in before you can comment on or make changes to this bug.