Bug 264301 - vdso gettimeofday wonky with 2.6.23-rc3-mm1 kernel
vdso gettimeofday wonky with 2.6.23-rc3-mm1 kernel
Status: CLOSED DUPLICATE of bug 262481
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
: 258281 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-29 13:08 EDT by Valdis Kletnieks
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 13:14:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2007-08-29 13:08:19 EDT
Description of problem:
After installing glibc 2.6.90-13, the system time as reported by gettimeofday()
started misbehaving - the first 5 minutes of uptime it would be correct, but
after the 5-minute jiffies rollover, the time reported by 'date' and other
programs would jump ahead 4096 seconds.  'uptime' would still report the right
time, and 'touch foo; ls -l foo' would show correctly as well.  When booting
with 'vdso=0' things work properly. (This also affected xscreensaver, see bug
#258281)

Version-Release number of selected component (if applicable):
glibc-2.6.90-13

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Unclear if this is a glibc issue, or a borked vdso in the -mm kernel.
Comment 1 Valdis Kletnieks 2007-08-29 13:11:36 EDT
*** Bug 258281 has been marked as a duplicate of this bug. ***
Comment 2 Jakub Jelinek 2007-08-29 13:14:23 EDT

*** This bug has been marked as a duplicate of 262481 ***

Note You need to log in before you can comment on or make changes to this bug.