Bug 26437 - XFree86 server seems highly unstable
XFree86 server seems highly unstable
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86-Servers (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-07 01:44 EST by Jay Berkenbilt
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-07 01:44:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Berkenbilt 2001-02-07 01:44:29 EST
I apologize for this highly vague and relatively useless bug report, but I
have to put something in here.  I will try to provide more information. 
Information on what information to provide will be useful.

I am logging in via gdm.  I find that my X server crashes somewhat often. 
I will probably dump gdm for the duration of my fisher testing and start X
with xinit so that I can hopefully get a core file or something.

I don't know how to reproduce the X server crashes, but I'll work on it. 
Sometimes the entire X server crashes after exiting from an application. 
vmware seems to do this pretty often.  I think I've had netscape do it
too.  I also got the X server into a state where it thought my ALT key was
down.  It was definitely not a keyboard problem.  After using CTRL-F1
(remember -- the system thinks I'm pressing ALT) to shift to another
virtual console, I had to use the alt key explicitly in the other console. 
I tried to kill running clients and the X server crashed in the process. 
After I logged back in, the keyboard behaved normally.

Again, I will try to set things up so I can get core files and maybe I can
figure out a way of reproducibly crashing the X server, but so far, X seems
to crash at least once every few hours.  (I'm running Fisher only at home
in the evenings and, unfortunately, during the wee hours of the
morning....)
Comment 1 Mike A. Harris 2001-02-08 06:50:52 EST
You need to provide all the hardware details, as well as config file and
xserver output attachments to the bug report.  Also, if you are running
VMware at ALL, the bug report is useless.  VMware installs kernel modules
which are proprietary and can hang the machine possibly.  In order to get
a useful report, you need to totally from a fresh boot NEVER load a vmware
module or run vmware - reproduce a crash/hang, and then submit a report.

Also, VMware uses DGA, and DGA is not completely solid in 4.0.x yet, so it
will likely have problems anyway.

Because vmware uses kernel modules anything can happen and I cant replicate
it or begin to fix it.  It must be replicated without any vmware kernel
modules having been loaded from boot.
Comment 2 Jay Berkenbilt 2001-02-08 15:35:38 EST
Thanks for this helpful response.  As there are lots of vmware-related problems,
I'm going to report this problem to vmware and suggest that they test under
Fisher if they aren't already doing so.  Hopefully someday soon plex86 or
another open source alternative to VMware will make its use unnecessary.  Thanks
for taking the trouble to respond even though vmware was involved.
Comment 3 Mike A. Harris 2001-02-08 17:03:43 EST
Ok great.  VMware is a cool tool, but when it is used and the machine
locks it's a real catch 22.  The kernel guys wont touch bug reports at all
if vmware is even in a 10 mile radius.  ;o)

plex86 is coming along though.  It is in powertools now I think. Dunno
how useful it is yet though.
Comment 4 Jay Berkenbilt 2001-02-21 14:25:46 EST
FWIW, I haven't had a single X server crash since I stopped running VMWare under
Fisher.

Note You need to log in before you can comment on or make changes to this bug.