Bug 26441 - No print filters can be found - missing package
No print filters can be found - missing package
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
Florence RC-1
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-07 02:58 EST by Daniel Hammer
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-10 14:43:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Hammer 2001-02-07 02:58:50 EST
From Bugzilla Helper: dhammer@noos.fr
User-Agent: Mozilla/4.76 [de] (X11; U; Linux 2.4.0-dh i686)


Reproducible: Always
Steps to Reproduce:
I tried to configure my printer (HP LaserJet 1100) using the new printconf
utility. Related packages I installed from fisher:
 o libgnomeprint11-0.25-1
 o printconf-gui-0.0-15
 o gnome-print-devel-0.25-1
 o gnome-print-0.25-1
 o printconf-0.0-15
But there's no way to find an appropriate print filter until I installed
also rhs-printfilters-1.81-1 from Red Hat 7.0 which has no own version on
the fisher CDs (1+2+powertools). This package is just missing and anyway
the new printtool looks quite confusing to me.
Comment 1 Glen Foster 2001-02-08 10:51:47 EST
We (Red Hat) should really try to resolve this before next release.
Comment 2 Crutcher Dunnavant 2001-02-08 11:35:58 EST
rhs-printfilters is not being shiped.
It is replaced by printconf, which does not depend upon it.

Do you mean that printconf did not have a driver for you?
Comment 3 Daniel Hammer 2001-02-09 05:26:42 EST
> Do you mean that printconf did not have a driver for you?
Yes, I tried printconf and it showed me its standard window. Than I opened a new
edit-window to add a printer ... two new windows popped up to tell me that no
network printer and ??? are available ... then after klicking "ok" my original
window vanished also. I tried this several times. After I installed
rhs-printfilters-1.81-1 from Red Hat 7.0 printconf asked me about my printer, I
took the right one and it worked.
Comment 4 Crutcher Dunnavant 2001-02-09 15:27:29 EST
There is absolutely no data shared between the packages.
rhs-printfilters and printconf are incompatable, I have no
idea what you've done to cause this behavior. printconf-gui
doesn't even suggest printers the way you describe.
Comment 5 Daniel Hammer 2001-02-10 14:43:22 EST
> I have no idea what you've done to cause this behavior
Uninstalled all relevant packages and started the whole thing from new.
Surprisingly it works now. I remember that I had some problems this night to get
the lpd deamon started.
Anyway, seems you're right 'n I did some (stupid) mistake, though I spent 1/2
hour on this. 'Can't remember exactly. So, thanx for your help 'n sorry for
bothering!
Comment 6 Crutcher Dunnavant 2001-02-12 11:35:08 EST
Sorry, sorry.
I didn't mean to sound snippy, I was just confused by your bugs.
If its a hisenbug (vanishes when you try to measure it), I gues I'll close it.
Comment 7 Daniel Hammer 2001-02-12 14:00:18 EST
> Sorry, sorry.
Ok. don't feel sorry - I was not upset by you comments!
But anyway my previous message was to optimistic. Let me summarize:
1.) with RH-7 my printer works perfect, he is correctly recognized
    and the driver works fine; dmesg gives: 
	parport0: PC-style at 0x378 (0x778) [SPP,ECP,ECPEPP,ECPPS2]
	parport0: detected irq 7; use procfs to enable interrupt-driven operation.
	parport_probe: succeeded
	parport0: Printer, Hewlett-Packard HP LaserJet 1100
	lp0: using parport0 (polling).

2.) Even if I run with RH-7 with a rawhide 2.4.0-0.99.11-kernel everything works
fine.

3.) With RH "fisher" nothing works anymore
    (a) Installing a driver for the printer via printtool works now
(surprisingly, since
        first I couldn't even start the lpd)
    (b) I could not print at all; when running "lpq" after "lpr something"
        I get a message like this:
          Printer: printer@bienchen 'printer'
          Queue: no printable jobs in queue
          Status: job 'cfK063bienchen.cybercable.tm.fr' removed at 19:03:27.302
    (c) under the new RH (stock) kernel "dmesg" looks as follows
         Winbond Super-IO detection, now testing ports 3F0,370,250,4E,2E ...
         Winbond chip at EFER=0x3f0 key=0x87 devid=97 devrev=73 oldid=ff
         Winbond chip type 83977TF / SMSC 97w33x/97w34x
         Winbond LPT Config: cr_30=01 60,61=0378 70=07 74=03, f0=3b
         Winbond LPT Config: active=yes, io=0x0378 irq=7, dma=3
         Winbond LPT Config: irqtype=pulsed low, high-Z, ECP fifo threshold=7
         Winbond LPT Config: Port mode=ECP and EPP-1.9
         SMSC Super-IO detection, now testing Ports 2F0, 370 ...
         0x378: FIFO is 16 bytes
         0x378: writeIntrThreshold is 9
         0x378: readIntrThreshold is 9
         0x378: PWord is 8 bits
         0x378: Interrupts are ISA-Pulses
         0x378: ECP port cfgA=0x10 cfgB=0x48
         0x378: ECP settings irq=7 dma=<none or set by other means>
         parport0: PC-style at 0x378 (0x778) [PCSPP,TRISTATE,COMPAT,EPP,ECP]
         parport0: irq 7 detected
         parport0: cpp_daisy: aa5500ff(98)
         parport0: assign_addrs: aa5500ff(98)
         parport0: faking semi-colon
         parport0: Printer, Hewlett-Packard HP
         lp0: using parport0 (polling).
         lp0: console ready

Still I have no idea. Seems to me that something perhaps is wrong with the
parport kernel module.

Note You need to log in before you can comment on or make changes to this bug.