Bug 26453 - Testing X configuration fails erroneously
Testing X configuration fails erroneously
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-07 07:12 EST by Phil Venton
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-16 12:04:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Venton 2001-02-07 07:12:46 EST
Hardware:
Dual P-II 400, on QDI BrilliantIV (440BX, BIOS version 3 beta)
Diamond V770 Ultra (TNT2 ultra chipset)
Samsung SL900+ (using probed DDC syncs)
256megs RAM
6 Gig Maxtor over UDMA/33 on /dev/hdc
USB mouse (Razer Boomslang 2K)

Install parameters:
Custom install, all packages.
Automatic partitioning
X selected at 1280x1024, 24 bit.
Dual-booting with Win2K (on /dev/hda1, whole disk)

Testing the X config fails with "Explicit kill or server shutdown".
However, the resulting XF86Config-4 file is perfect, and startx (or booting
to init 5) works flawlessly post-install.
Comment 1 Michael Fulbright 2001-02-07 11:27:32 EST
Assigning to a developer.
Comment 2 Phil Venton 2001-02-07 12:44:45 EST
I should also mention, in case it is relevant:

The V770 has 32 megs video RAM, but anaconda detected it as 16.  I changed it to
32 from the dropdown.

I will hammer on this with some other settings when I have free time, and see
what the reproducable envelope is.
Comment 3 Brent Fox 2001-02-07 13:28:47 EST
Can you go to VC2, run ddcprobe, and post the output?  That way we can tell how
much memory the card thinks it has.
Comment 4 Glen Foster 2001-02-08 11:01:06 EST
We (Red Hat) should really try to resolve this before next release.
Comment 5 Tim Waugh 2001-02-09 13:04:27 EST
You might also want to look at /tmp/XF86Config-4 (or whatever it's called after
clicking on the test button, to see what the differences are between that and
the installed Xconfigurator config file.
Comment 6 Brent Fox 2001-02-16 12:04:54 EST
We think this has been fixed in the latest internal builds.  There was a problem
in the way we were handling memory.  Basically, testing X caused a spike in
memory usage, and the kernel was killing the X process because it thought it had
run out of memory.  Please reopen if the problem persists.

Note You need to log in before you can comment on or make changes to this bug.