Bug 26467 - tftp config for xinetd broken
Summary: tftp config for xinetd broken
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tftp (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Helge Deller
QA Contact: David Lawrence
URL:
Whiteboard: Florence Gold
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-07 15:56 UTC by chrismcc
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-08 17:17:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description chrismcc 2001-02-07 15:56:11 UTC
tftp config for xinetd broken

There is no protocol line, should be udp
the orig tries to log the username.  Username with tftp?
 
NOTE: tftp put does work! 



This works:
[chrismcc@wednesday chrismcc]$ cat /etc/xinetd.d/tftp 
# default: off
# description: The tftp server serves files using the trivial file transfer \
#
protocol.  The tftp protocol is often used to boot diskless \
#
workstations, download configuration files to network-aware printers, \
#
and to start the installation process for some operating systems.
service tftp
{
	disable	= no
	socket_type		= dgram
	wait			= yes
	protocol		= udp
	user			= root
	server			= /usr/sbin/in.tftpd
	server_args		= -s /tftpboot
}

Comment 1 Pekka Savola 2001-02-07 16:45:29 UTC
dgram socket type defaults to udp.  The default configuration works for me in a normal setup.

However, on one box where I have IPv6 activated, running xinetd will make tftpd die of 
errno 93 (Protocol not supported) unless udp has been defined.

Good point about user name logging.



Comment 2 chrismcc 2001-02-07 17:28:34 UTC
I don't have ipv6 setup; unless something sets up something on install (clean)
Oops, 'wait' should be yes, not no



Feb  7 06:39:03 wednesday xinetd[17781]: socket creation failed (Protocol not
supported (errno = 93)). service = tftp
Feb  7 06:42:32 wednesday xinetd[17862]: socket creation failed (Protocol not
supported (errno = 93)). service = tftp
Feb  7 06:45:51 wednesday xinetd[17889]: tftp service was deactivated because of
looping
Feb  7 14:45:51 wednesday tftpd[17896]: recvfrom: Resource temporarily unavailable



[root@wednesday log]# grep tftp secure  
Feb  7 06:45:51 wednesday xinetd[17889]: START: tftp pid=17895 from=192.168.9.253
...

It would be nice to log the filename accessed and if it was a 'put' or a 'get'.
 But thats an 'enhancement' not a bug :)




Comment 3 Glen Foster 2001-02-08 16:00:35 UTC
We (Red Hat) should really try to resolve this before next release.

Comment 4 Helge Deller 2001-02-08 17:17:01 UTC
I just fixed this, but it will take ~ 1-2 hours until I can put 
tftp-0.17-9.src.rpm through porkchop...


Note You need to log in before you can comment on or make changes to this bug.