Bug 26496 - top CPU idle format incorrect
Summary: top CPU idle format incorrect
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: procps
Version: 7.0
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-07 17:19 UTC by Clarence Donath
Modified: 2008-05-01 15:37 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-02-15 15:21:41 UTC


Attachments (Terms of Use)

Description Clarence Donath 2001-02-07 17:19:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)


Using a dual processor configuration with Linux SMP during full processor 
utilitization, CPU state idle shows negative values in the form '0.-1%'

Reproducible: Always
Steps to Reproduce:
1. Run two instances of setiathome so both CPU's are fully utilized
2. Observe CPU0 and CPU1 idle states
3.
	

Actual Results:  CPU0 and CPU1 states will mostly show 0.0% idle, but 
occassionally show 0.-1% idle.

Expected Results:  Wouldn't expect to see negative idle values, but if 
such a value is valid, should be -0.1% instead of 0.-1%.

top, uptime and ps do not show up in BugZilla's component list, so I 
posted this under 'mysterious'.

Comment 1 Clarence Donath 2001-05-17 15:06:50 UTC
This is no longer an issue with the 2.4.x kernel and Red Hat 7.1


Note You need to log in before you can comment on or make changes to this bug.