Bug 26502 - network-functions-ipv6 "missing option" should be "missing parameter"
Summary: network-functions-ipv6 "missing option" should be "missing parameter"
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-07 18:09 UTC by Christian Rose
Modified: 2014-03-17 02:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-07 23:09:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christian Rose 2001-02-07 18:09:38 UTC
#: /etc/sysconfig/network-scripts/network-functions-ipv6:176
#: /etc/sysconfig/network-scripts/network-functions-ipv6:225
msgid "Missing option 'IPv6-route'"

#: /etc/sysconfig/network-scripts/network-functions-ipv6:124
msgid "Missing option IPv6-network'"

#: /etc/sysconfig/network-scripts/network-functions-ipv6:92
msgid "Missing option 'IPv6-network'"

#: /etc/sysconfig/network-scripts/network-functions-ipv6:281
#: /etc/sysconfig/network-scripts/network-functions-ipv6:322
msgid "Missing option 'Prefixlength'"

#: /etc/sysconfig/network-scripts/network-functions-ipv6:164
#: /etc/sysconfig/network-scripts/network-functions-ipv6:213
#: /etc/sysconfig/network-scripts/network-functions-ipv6:269
#: /etc/sysconfig/network-scripts/network-functions-ipv6:310
msgid "Missing option 'device'"

#: /etc/sysconfig/network-scripts/network-functions-ipv6:275
#: /etc/sysconfig/network-scripts/network-functions-ipv6:316
msgid "Missing option 'IPv6-address'"

#: /etc/sysconfig/network-scripts/network-functions-ipv6:170
#: /etc/sysconfig/network-scripts/network-functions-ipv6:219
msgid "Missing option 'IPv4-tunneladdress'"

#: /etc/sysconfig/network-scripts/network-functions-ipv6:98
#: /etc/sysconfig/network-scripts/network-functions-ipv6:130
msgid "Missing option 'IPv6-gateway'"


All these messages could probably reduced to one single message of the type
"Missing option ''$MISSING_OPTION"

The reason is that the name of the option shouldn't be translated anyway,
so a change like this will save translators from having to translate a
message for every single option.

Comment 1 Bill Nottingham 2001-02-07 22:46:37 UTC
It's not the name of the option; it's a description of what the option
represents.

Comment 2 Christian Rose 2001-02-07 23:03:11 UTC
Ok, I guess it was the quotes around it that confused me to belive it was option
names.

Well, then this is not a bug.

Comment 3 Christian Rose 2001-02-07 23:09:25 UTC
Come to think of it, maybe "option" in these messages should be replaced by
"parameter" then.
These are really parameters, no?

Examples:
"cp -r foo"
Here, "foo" is a parameter, and "-r" is an option. This is my picture of the
nomenclature =)

So if the "options" here are used as "parameters", maybe they should be renamed
to reflect that. Reopening.

Comment 4 Bill Nottingham 2001-02-08 00:52:08 UTC
Will be changed in 5.63-1.


Note You need to log in before you can comment on or make changes to this bug.