Bug 26532 - 3D support is not auto-configured
Summary: 3D support is not auto-configured
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard: Florence RC-1
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-07 21:29 UTC by stephan schutter
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-11 16:24:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description stephan schutter 2001-02-07 21:29:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0; MSN 6.0)


During setup the X-configuration tool correctly detects the 3DFX Voodoo 3 
3000 card and installs X4. Despite this, setup knows that I have a voodoo 
card (why per tell might I have bought this High end [3D] card?), but it 
does not configure Glide or OpenGL. Clearly, this can be done... 

Reproducible: Always
Steps to Reproduce:
1. Install a voodoo 3 3000 card
2. Install RH Linux "fisher"
3. Try installing a game that requires 3D accelleration.



Actual Results:  voila! Game dies when you try to run it. [Quake III, 
decent 3, et all. from Loki] To bad.
	

Expected Results:  Kernel 2.4 (PNP), and X should be properly configured 
when a high end 3D card (NVidia, Voodoo, Matrox G 400 etc.) is discovered.

This is not a show stopper since X does configure for 2D at least... But 
the waste in agregate man-hours to find the documentation on how to 
manually find the rpms for 3D support, install them, and mess with the X 
config file, is incredible. This can be considered a bug because this can 
be seen as a misconfiguration of hardware.

I do not know if this bug should belong to Glide3 or X... probably both...

Thank you for listening.

Comment 1 Bill Nottingham 2001-02-07 21:32:28 UTC
This is an X bug, a required file (tdfx_dri.so) is missing.

Comment 2 Glen Foster 2001-02-08 15:51:56 UTC
We (Red Hat) should really try to resolve this before next release.

Comment 3 Mike A. Harris 2001-02-11 16:23:25 UTC
This is a duplicate bug (don't have the number handy) and it has already
been fixed in the last build.  You can find an update in RAWHIDE.  Please
send me an email if this build works for you.  If not, bugzilla any problems.


Note You need to log in before you can comment on or make changes to this bug.