Bug 26536 - Installer crashed before copying files from cd1
Summary: Installer crashed before copying files from cd1
Status: CLOSED DUPLICATE of bug 18032
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-07 21:40 UTC by Florent Busi
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-08 18:48:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Florent Busi 2001-02-07 21:40:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt; KITV5 
Wanadoo)


when i use the 'custom setup' (actually i'm using the french 'systeme 
personnalise'), and choose for over 1.5G of package to be installed on a 
hdc6 partition (/) {i also got a 250M /hda5 <=> /home ; a 19M /boot <=> 
hda6 ; and a hda8 100M swap partition}

Reproducible: Always
Steps to Reproduce:
1.choose custom setup
2.partition with disk druid ...
3.select ~1.5G of packages to be installed on / (2G)
4.formating goes on and then just before files can be copied i got a 
message error saying me that it might be a bug and that i should write to 
you to explain what happened! I actually got this file i saved on a floppy 
before rebooting

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 
doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + 
\
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in 
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + 
mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'Aucun fichier ou r\351pertoire de ce type')

Local variables in innermost frame:
fsystem: /mnt/sysimage//mnt/hda1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

	

Actual Results:  the copy of the files does not occur and instead i got an 
error message and then the system reboot when i clic ok


Expected Results:  Files should have been copied to my hdd in order to 
complete installation, allowing me to run my red hat os

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 
doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + 
\
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in 
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + 
mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'Aucun fichier ou r\351pertoire de ce type')

Local variables in innermost frame:
fsystem: /mnt/sysimage//mnt/hda1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 1 Michael Fulbright 2001-02-08 17:40:43 UTC
What is on /dev/hda1?

Comment 2 Florent Busi 2001-02-08 18:48:14 UTC
On /dev/hda1 (700M), i have a fat16 partition with windows 98.

these are my hdd configurations:

hda1 700M DOS 16-bit>=32
hda5 250M linux native
hda6 19M  linux native
hda7 1063M linux native
hda8 100M <swap>  (i have 48M RAM)

hdc1 2047M DOS 16-bit>=32
hdc5 2047M DOS 16-bit>=32
hdc6 2047M linux native

When installing i first tried:
hda7 1063M being /, and
hdc6 2047M being /usr
I chose for ~1.5G package (thinking most of it would be installed on /usr)
and i had this message.
Then i thought my / partition was too tiny and i tried installing it (/) on 
hdc6 (2047M being greater than 1.5G) and got the same message.

Comment 3 Michael Fulbright 2001-02-08 20:44:32 UTC

*** This bug has been marked as a duplicate of 18032 ***


Note You need to log in before you can comment on or make changes to this bug.