Bug 26557 - Installer crashes during fresh text mode install of RH 7.0
Installer crashes during fresh text mode install of RH 7.0
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-02-07 17:36 EST by James Evans
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-02-08 12:38:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description James Evans 2001-02-07 17:36:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i686)

I was attempting to install RH 7.0 from bootable CD via text mode.  There's
a small ext2 Linux partition (54M) that I am using for /boot, a big, FAT32
partition for Win2000, a 720MB FAT32 partition, a big ext2 partition for
Linux and a 125MB Linux swap partition.  The are in that order from left to
right, with only the 54MB /boot partition and the big FAT32 partition being
primary, and the others being logical.

I labeled the 54MB partition /boot and made the main ext2 partition just
/.  I chose to install LILO on the boot sector of hda3 and added a
selection for Win2000 and Linux.  When it came time to choose the packages,
I selected each package manually and also selected to install everything
and select individual packages.  Inside of that, I left all selected
packages and added to the X-Server section the Rage 64 server and the SVGA
server.  Chose not to configure X at the time.  I started the install and
after it formatted the drives, anaconda crashed so I wrote the log to a

Reproducible: Always
Steps to Reproduce:
I had the crash happen two more times when attempting to install as above. 
My co-worker tried the install for me, but didn't add Win2000 to LILO and
didn't add the other X-Servers (SVGA and Rage 64).  This time, the install

Actual Results:  When I tried to repeat the install as I originally did, it
crashed each additional time.

Expected Results:  It should have installed Linux.

I created the drive partitions using Partition Magic 6.0 under Win 2000. 
Only the 54M /boot partition and the Big FAT32 partition were primary
partitions.  (the others were logical partitions)

Here is the error log from the floppy:
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in
    if self.method.systemMounted (self.fstab, self.instPath,
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] +
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' +
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//temp_cd

ToDo object:

Comment 1 Michael Fulbright 2001-02-08 12:38:41 EST

*** This bug has been marked as a duplicate of 18032 ***

Note You need to log in before you can comment on or make changes to this bug.