Bug 26561 - directories installed although contained in %_netsharedpath
Summary: directories installed although contained in %_netsharedpath
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-07 22:43 UTC by Enrico Scholz
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-07 22:43:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2001-02-07 22:43:42 UTC
When having e.g. /usr/share as %_netsharedpath, packages owning this
directory will try to create this directory.

That is caused by skipFiles() in lib/transactions.c whcih compares only
`fi->dnl' with the entries of %_netsharedpath.

But because `fi->dnl' equals to "/usr" for the directory '/usr/share' (the
`share' is in fi->bnl), the %_netsharedpath entry won't be hit and
`/usr/share' be installed.

Comment 1 Jeff Johnson 2001-04-03 20:51:00 UTC
Fixed in rpm CVS, will be in rpm-4.0.3-0.4 and later.


Note You need to log in before you can comment on or make changes to this bug.