Bug 265801 - fuser command not found by kio_media_mounthelper
fuser command not found by kio_media_mounthelper
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
6
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-29 18:49 EDT by Wojciech Pilorz
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-30 09:32:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wojciech Pilorz 2007-08-29 18:49:30 EDT
Description of problem:
When a button is pressed on a CD/DVD drive with mounted media,
kio_media_mounthelper displays it cannot found
fuser command (trying to determine, wheter the mounted 
  filesystem is in use)
The exact message is
/usr/bin/env: fuser: No such file or directory

Version-Release number of selected component (if applicable):
kdebase-3.5.7-0.1.fc6.i386

How reproducible:
Always on fc6+kde, non-root user

Steps to Reproduce:
1. mount a CD or DVD using mount command
2. press eject button on CD/DVD drive
3. watch kio_media_mounthelper window contents
  
Actual results:
fuser is called without path, however, fuser is not in $PATH
for non-root user

Expected results:
Should display processed using media

Additional info:
as a workaround, because ~/bin is in $PATH,
after
ln -s /sbin/fuser ~/bin
the kio_media_mounthelper message is as expected (fuser successfully called)
BTW. 
My setup is modified so that media does not get automatically mounted,
Comment 1 Rex Dieter 2007-08-29 19:09:21 EDT
Right, fuser is only in root's path.

Coulda sworn we had patched to fix this?? Will take a closer look.
Comment 2 Ngo Than 2007-08-30 09:32:22 EDT
it's fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.