Bug 265961 - compile_et uses gawk but e2fsprogs-devel doesn't "require" it
compile_et uses gawk but e2fsprogs-devel doesn't "require" it
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
rawhide
All All
medium Severity low
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-29 20:51 EDT by Nalin Dahyabhai
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: e2fsprogs-1.40.2-4.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 22:12:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2007-08-29 20:51:36 EDT
Description of problem:
The compile_et script uses gawk, but e2fsprogs-devel doesn't require the gawk
package or binary.  Because gawk isn't in the default build environment any
more, this causes packages which require e2fsprogs-devel or compile_et to fail
to build unless they require gawk directly, even if they don't otherwise use gawk.

Version-Release number of selected component (if applicable):
1.40.2-2.fc8

How reproducible:
Always
Comment 1 Eric Sandeen 2007-08-29 21:38:32 EDT
Urgh... I fixed up the BR: for e2fsprogs itself, but didn't think about this. 
Thanks, I'll get it fixed.

-Eric
Comment 2 Eric Sandeen 2007-08-29 22:12:42 EDT
Fixed in e2fsprogs-1.40.2-4.fc8

Note You need to log in before you can comment on or make changes to this bug.