Bug 266 - IP masquerader doesn't work properly on high value ports
IP masquerader doesn't work properly on high value ports
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
5.2
All Linux
low Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
: 279 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-02 15:08 EST by ah313
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-29 11:43:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ah313 1998-12-02 15:08:48 EST
When using a FTP client behind a IP masquerader, and
trying to connect to a FTP site that runs on port 41181,
the masquerader doesn't work properly.

Connection is established, but the FTP client just hangs.
IE: you cannot get a directory listing for example, or
do any other operations.  I haven't done extensive testing
to see what other ports it fails on, but I have a feeling
the IP masquerader does not work properly work on any
port beyond 32767 (2^15 - 1).  The machine behind the IP
masquerader was a Win95 running CuteFTP 2.6.  I also tried
the FTP client in the DOS prompt, and identical results.
Therefore I doubt this is a client problem.
Comment 1 Bill Nottingham 1998-12-03 14:08:59 EST
*** Bug 279 has been marked as a duplicate of this bug. ***
Comment 2 Cristian Gafton 1999-07-29 11:43:59 EDT
Is this still valid for the 2.2 kernel?  Or is this happening because
passive FTP should have been used?

Reopen if still valid

Note You need to log in before you can comment on or make changes to this bug.