Bug 26650 - ping only returns one line
ping only returns one line
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: iputils (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-07 22:44 EST by Ravindran Karupiah
Modified: 2015-03-04 20:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-17 11:08:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravindran Karupiah 2001-02-07 22:44:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)


ping only returns one line until Ctrl-C

Reproducible: Always
Steps to Reproduce:
1.run ping
2.
3.
	

Actual Results:  apollo# ping localhost
PING localhost (127.0.0.1) from 127.0.0.1 : 56(84) bytes of data.
64 bytes from localhost (127.0.0.1): icmp_seq=0 ttl=255 time=0.3 ms
r
--- localhost ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max = 0.3/0.3/0.3 ms
Comment 1 Pekka Savola 2001-02-12 16:38:03 EST
1. which version of ping?  If not the errata, try updating.
2. does this happen with non-localhost too?  
3. ping -n is bad too? 
4. you haven't tweaked /proc/sys/net/ipv4/icmp_echo* ?
5. what does 'tcpdump -n icmp' say ?
Comment 2 Ravindran Karupiah 2001-02-12 20:05:02 EST
1. which version of ping?  If not the errata, try updating.
       >> iputils-ss990107 and have updated but problem still there.

2. does this happen with non-localhost too?
       >> yes
  
3. ping -n is bad too? 
       >> yes, same

4. you haven't tweaked /proc/sys/net/ipv4/icmp_echo* ?
       >> no

5. what does 'tcpdump -n icmp' say ?
       >> when ping is executed only the following appears.

# tcpdump -n icmp
Kernel filter, protocol ALL, datagram packet socket
tcpdump: listening on all devices
16:04:37.475973   lo > 127.0.0.1 > 127.0.0.1: icmp: echo request
16:04:37.475973   lo < 127.0.0.1 > 127.0.0.1: icmp: echo request
16:04:37.476058   lo > 127.0.0.1 > 127.0.0.1: icmp: echo reply
16:04:37.476058   lo < 127.0.0.1 > 127.0.0.1: icmp: echo reply
Comment 3 Curtis Doty 2001-05-14 21:57:49 EDT
Had same problem with netkit-base-0.10-37 and upgraded to iputils-20001110-1 
where I now get the error with a warning: no SO_TIMESTAMP support, falling back 
to SIOCGSTAMP. Are they connected? Kernel is 2.2. tcpdump icmp shows only one 
echo request and its reply no matter what I do with -c and -w.
Comment 4 Phil Knirsch 2001-06-26 08:33:20 EDT
Could you offer some more info, maybe of the hardware you are using?

I remember some strange things happening with older 486 boards, maybe it could
be some kind of hardware problem where timers don't work correctly.

Otherwise i'd recommend to upgrade the system to 7.1 and see if the problem
still occurs. The new kernel and new iptutils package might solve it.

Read ya, Phil
Comment 5 Pekka Savola 2001-07-17 11:07:57 EDT
I happened to come across this:

http://marc.theaimsgroup.com/?l=linux-kernel&m=99537155120225&w=2

List:     linux-kernel
Subject:  alarm() does not work/ping only sends one packet on SMP machine (2.2.16)
From:     Tobias Haustein <tobias.haustein@aixigo.de>
Date:     2001-07-17 12:02:07

Might be related; the behaviour at least seems vaguely familiar.

Comment 6 Phil Knirsch 2002-03-12 08:34:22 EST
As i can't reproduce this bug and as it looks like it might be a kernel problem
i am closing this bug as 'WORKSFORME' now.

Please try with latest kernel/glibc and iputils (I've tried various setups with
kernel 2.2 and 2.4).

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.