Bug 266741 - dejavu-fonts: Condensed variants (in -experimental) not available
dejavu-fonts: Condensed variants (in -experimental) not available
Status: CLOSED DUPLICATE of bug 272521
Product: Fedora
Classification: Fedora
Component: dejavu-fonts (Show other bugs)
7
All All
low Severity low
: ---
: ---
Assigned To: Nicolas Mailhot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-30 08:00 EDT by Rex Dieter
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-01 04:38:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2007-08-30 08:00:57 EDT
I can't seem to use use any of the Condensed variants included in the
-experimental subpkg.  In both kde's Kcontrol and gnome-font-properties, they
are simply not listed.

Maybe it's fontconfig bug/issue. ??

Anyway, the only oddity I can find is using fc-list:
$ fc-list | grep Deja | grep Condensed
DejaVu Serif,DejaVu Serif Condensed:style=Condensed,Book
...

It seem to list both "DejaVu Serif" and "DejaVu Serif Condensed" as the font
name here, so only the first one seems to be used anywhere.  ??
Comment 1 Nicolas Mailhot 2007-08-31 05:20:23 EDT
There are many bugs in apps when handling font styles other than the 4 legacy
normal/bold/italic/bold-italic

I'll check but I think a lot of those are fixed in -devel.

If this is so we may need a workaround for F7, but not sure it will be an easy
one. I don't have a F7 system to test on BTW
Comment 2 Nicolas Mailhot 2007-08-31 07:19:13 EDT
Could you check if the -devel dejavu packages fix your problem ? They are a tad
more up to date than the F7 ones
Comment 3 Rex Dieter 2007-08-31 08:13:33 EDT
All I can say is that is a bit of a regression for me, DejaVu Sans/Serif
Condensed worked fine when I was stuck back on centos4 (and I fell in love with
them), but I miss 'em after upgrading to f7.

OK,
yum --enablerepo=development install dejavu-fonts-experimental
and... nothing, no change.

fwiw, I can't see the LGC Condensed variants either. 

I'm starting to think this is perhaps more a fontconfig issue.  ??


Comment 4 Nicolas Mailhot 2007-08-31 08:55:59 EDT
IIRC there were some ugly workarounds in older dejavu versions to deal with apps
that only understand the 4 legacy names, and they were dropped a few releases
ago. Will investigate
Comment 5 Nicolas Mailhot 2007-08-31 08:57:46 EDT
do the packages you used in centos4 work in F7 ?
Comment 6 Nicolas Mailhot 2007-08-31 17:43:53 EDT
Also, did you check in gnome-font-properties if you do not have condensed as a
style of dejavu sans (instead of a "dejavu sans condensed" font with a "regular"
style) ???
Comment 7 Rex Dieter 2007-08-31 17:54:17 EDT
Well I'll be... you're right, they do show in gnome-font-properties that way...
maybe then just a limitation in kde's font selection.  I'll keep looking...
Comment 8 Rex Dieter 2007-08-31 17:55:19 EDT
firefox/thunderbird are comical, they list Dejavu-Sans multiple times (and don't
mention/display styles).
Comment 9 Nicolas Mailhot 2007-09-01 04:38:54 EDT
(In reply to comment #7)
> Well I'll be... you're right, they do show in gnome-font-properties that way...
> maybe then just a limitation in kde's font selection.  I'll keep looking...

Ok, that means the fonts and the base infrastructure are fine, and individual
apps have problem handling fonts with many styles

Thus it's not a bug in fontconfig or dejavu but several separate application bugs

I'll close this entry now. Please check if every issue you encounter is filed as
a blocker of bug #272521, and if not enter a new bug and make it block this tracker



*** This bug has been marked as a duplicate of 272521 ***

Note You need to log in before you can comment on or make changes to this bug.