Bug 266761 - python-setuptools installs site.py, conflict?
python-setuptools installs site.py, conflict?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-setuptools (Show other bugs)
7
x86_64 All
medium Severity medium
: ---
: ---
Assigned To: Konstantin Ryabitsev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-30 08:05 EDT by Neal Becker
Modified: 2008-05-07 18:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-07 18:53:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2007-08-30 08:05:14 EDT
Description of problem:

On x86_64, python-setuptools installs:
/usr/lib/python2.5/site-packages/site.py

Doesn't this conflict with:
/usr/lib64/python2.5/site.py?
 rpm -qf /usr/lib64/python2.5/site.py
python-2.5-12.fc7

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Toshio Ernie Kuratomi 2007-08-31 11:58:07 EDT
I believe this is by design although this:
  http://peak.telecommunity.com/DevCenter/Python25

says that site.py moved to site-patch.py.  Hmm...
Comment 2 Toshio Ernie Kuratomi 2007-09-05 15:44:13 EDT
Okay.  It looks like what happens is that setuptools includes site.py as
site-patch.py.  It then proceeds to install site.py for any package which
installs an egg.  This includes setuptools itself; thus the site.py installation.

setuptools needs to install this site.py file because it relies on using .pth
files to add eggs into the path before site-packages (python's site.py only
allows appending to the path.)

Neal, does the setuptools site.py actually break anything?
Comment 3 Toshio Ernie Kuratomi 2008-05-07 18:53:34 EDT
Closing bug as this is by design.  If it causes problemswe can revisit.

Note You need to log in before you can comment on or make changes to this bug.